Bluetooth redirection in GNOME Boxes, killed bluetooth on my host machine

I have a Framework Laptop with Fedora 37 installed.

I was using GNOME Boxes to run Windows 11. I tried redirecting my bluetooth to the VM so I could connect my logitech keyboard and mouse to the Logi+ app. Doing so disabled bluetooth on the host machine. When I tried toggling that option off using the laptop’s trackpad, GNOME Boxes became unresponsive.

Restarted the host machine then restarted the VM to turn off the redirection but the option for bluetooth is gone. Multiple restarts also won’t renable bluetooth on my host machine

Ran in terminal

lsusb -v | grep Bluetooth | grep DeviceProtocol


Couldn't open device, some information will be missing

Welcome to ask.fedora @michaelkronenberg

Please read #start-here if you not done already.

If you have virtualization normally there is no need to use a extra keyboard for virtual environments you are running on your host.

If you tell us what you want to achieve with this we do might find a other solution for your effective problem. For me it looks like that you try to update a firmware who just works on Windows ?

Thanks @ilikelinux I tried putting as many correct tags as I could on my post. I didn’t put it in the common issues category because I’m not sure how common this issue is. It is certainly a problem from a UX perspective.

Luckily I was able to restore my bluetooth on my host machine. In my panic I tried a bunch of terminal commands, none of them seemed to work, though after restarting my computer for the 3rd time it magically returned.

Here are some of the things I tried.

systemctl enable bluetooth
systemctl start bluetooth
sudo rmod btusb
sudo modprobe btusb
sudo rfkill unblock bluetooth

In terms of what I was trying to accomplish, yes check and update the firmware on my Logitech mouse and keyboard. Remap the 3 available connections for each device. The workaround is that I can connect them using their USB receivers.

From a UX perspective it’s a big problem to lose your Bluetooth capability on your host machine. There was no warning about the possible consequences, there was no documentation on how to restore bluetooth to the host machine. If anyone sees this post, I’m a UX designer and I would be interested in collaborating with a maintainer of this project to fix this issue.

I do agree, but i would have achieved this with a win10/11 boot iso and tried to check update your system this way. So your Fedora wouldn’t have be affected. In my time when I worked for corporated companies we had a windows boot iso. Bart-CD was the name from the Windows-XT/7 I had one. Microsoft offered a own one.

As soon as you use the SUDO account, you have to be aware that you can brick your System if yo not know exactly what you are doing. The system does not know your knowledge level and does not have a built in warning if the command is legit while working as an elevated user. The fault is in this case on your side :slight_smile:

About the documentation feel free to participate doing one:

I guess this one who resurrected the Bluetooth again :laughing:

This is just a small group who selects and adds to this group.


Where can I find more information about Windows boot iso? It looks like BartPE (what google returns) is long discontinued BartPE - Wikipedia

The action to share bluetooth is a GUI based action. not using sudo in the terminal. See the screenshot.

I agree that rfkill unblock bluetooth was the most likely action that restored bluetooth to the host machine. It was the last command that I ran. The restoration did not happen until I after rebooting

sudo rfkill unblock bluetooth
1 Like

As i mentioned, I said Windows quite a long time ago good bye. But a quick googling showed that it is still possible to do a working boot medium from an existing Windows installation.

I hope this helps.

It is also directly possible to download an ISO for booting.