Bluetooth always turned on after power on or resume from suspend on Silverblue 35

Hi, I got an annoying problem with a laptop running latest silverblue 35. I clean installed silverblue 34 a while back (the problem occurred there too), and did not customize the system in any way I imagine could affect bluetooth, and bluetooth also works.
But every time I resume from suspend or power on, bluetooth is always on, even if it was toggled off. I don’t see anything related to that in the journal. Does this happen to you too, or is it a bug with my installation/hardware?


Did you have bluetooth dongle placed on your USB port during the boot? Also if you’re not using wifi, you could use “Airplane Mode” on (Gnome Setting > Wifi then Toggle “Airplane Mode”). It will disable all radio based communication (Wifi, Bluetooth, Mobile Broadband).

It is a laptop, so bluetooth is always connected to the PCIe bus as part of the wifi adapter. I still want to use WiFi, obviously, so airplane mode is not a solution for me, sadly. Is the behavior I am experiencing normal? I feel like bluetooth shouldn’t turn on by itself once I toggled it off…

I means bluetooth dongle for wireless keyboard or mouse or audio with higher series if any. Sometime we need to add bluetooth dongle with higher series (5) if our current bluetooth on laptop too lagging when playing sound.

Btw, I tried couples scenarios with bluetooth on or off with suspend and reboot with my Fedora Workstation and the problem didn’t shown as yours. Tonight I have a plan to install Fedora Silverblue on my laptop. I’ll inform you if I found same problem.

That would be great if you test this. I can file a bug with the devs afterwards.

Lucky for me, it’s all ok here. I try both suspend and reboot also poweroff-then-poweron, the bluetooth stay off. :sweat_smile:

1 Like

It looks like not, @oprizal please post the kernel you use that @thecuriousmind can test it to see if he has success.

I experienced the same issue on every kernel since July (when I first installed Silverblue)

I have 5.14.10 and 5.15.6 with all work fine.

The same issue that was marked as solved but didn’t really get solved happens to me on a new install of Fedora 36, too:

Everytime after reboot, I need to turn off Bluetooth when I don’t want to use it.

I found, bluetooth.service starts very early during boot. I am not used to this behavior, and usually when I turn it off on other systems, it also stays off after reboot.

Not on Fedora 36 (on both Gnome-, and Xfce-DE) on this machine:

$ inxi -Fzxa
  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36
    parameters: BOOT_IMAGE=(hd1,gpt7)/vmlinuz-5.18.7-200.fc36.x86_64
    root=UUID=511b4741-ab42-4bd8-9d2b-26b4e6d4d71f ro rootflags=subvol=root
    nomodeset rhgb quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 2 dm: 1: GDM v: 42.0 2: LightDM v: 1.30.0 note: stopped
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Apple product: iMac11,1 v: 1.0
    serial: <superuser required> Chassis: type: 13 v: Mac-F2268DAE
    serial: <superuser required>
  Mobo: Apple model: Mac-F2268DAE serial: <superuser required> UEFI: Apple
    v: date: 06/14/2019
  Info: model: Intel Core i7 860 bits: 64 type: MT MCP arch: Nehalem
    gen: core 1 built: 2008-10 process: Intel 45nm family: 6
    model-id: 0x1E (30) stepping: 5 microcode: 0xA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1370 high: 1919 min/max: 1197/2794 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1919 2: 1197
    3: 1197 4: 1197 5: 1197 6: 1450 7: 1611 8: 1197 bogomips: 44688
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD RV770/M98L [Mobility Radeon HD 4850] vendor: Apple
    driver: N/A alternate: radeon, amdgpu arch: TeraScale process: TSMC 55-65nm
    built: 2005-13 pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 1002:944a class-ID: 0300
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo
    bus-ID: 2-1.1:3 chip-ID: 05ac:8502 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.2
    compositor: xfwm v: 4.16.1 driver: X: loaded: modesetting,vesa
    unloaded: fbdev,radeon gpu: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: Unknown-1 mapped: None-1 res: 1920x1080 hz: 60 size: N/A
    modes: 1920x1080
  OpenGL: renderer: llvmpipe (LLVM 14.0.0 128 bits) v: 4.5 Mesa 22.1.2
    direct render: Yes
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Device-2: AMD RV770 HDMI Audio [Radeon HD 4850/4870] vendor: Apple
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 1002:aa30 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.7-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:1684 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR928X Wireless Network Adapter
    vendor: Apple AirPort Extreme driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:002a
    class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Device-1: Apple Built-in Bluetooth 2.0+EDR HCI type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.1.1:5 chip-ID: 05ac:8215 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 931.51 GiB used: 17.73 GiB (1.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST31000528ASQ
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: AP24 scheme: GPT
  ID-1: / raw-size: 53.48 GiB size: 53.48 GiB (100.00%)
    used: 17.4 GiB (32.5%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 299.9 MiB (30.8%) fs: ext4 dev: /dev/sda7 maj-min: 8:7
  ID-3: /boot/efi raw-size: 600 MiB size: 600 MiB (100.00%)
    used: 30.6 MiB (5.1%) fs: hfsplus dev: /dev/sda6 maj-min: 8:6
  ID-4: /home raw-size: 53.48 GiB size: 53.48 GiB (100.00%)
    used: 17.4 GiB (32.5%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 1549
  Processes: 282 Uptime: 38m wakeups: 0 Memory: 15.5 GiB
  used: 2.15 GiB (13.8%) Init: systemd v: 250 target: graphical (5)
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 Packages:
  note: see --pkg flatpak: 11 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.19

It would be an easy thing turning off bluetooth.service, but once or twice in a week I need my BT headphones, so I don’t think this is really a viable solution.

On the net, i found a bug reported on redhat bugzilla that has persisted over 10 plus(!!!) years or so. But off course, many, many more people have other Bluetooth issues, such as not working at all, or bad sound, etc.

Any ideas lately? Anyone?!

Can you please start a new topic vice replying to previously solved topics.

On the blueman applet you may want to check.
Select Plugins → Power Manager, select configuration and verify auto power on is not checked.

1 Like

Just did.