Blender on Fedora 38 is missing core add-ons

Hi, I recently installed Fedora 38, and I’ve noticed that when installed latest Blender 3.5, it was missing core add-ons that are responsible for importing/exporting file formats such as fbx, gltf and so on. But if downloading Blender directly from website, all works as normal. Also tried installing Blender on Arch, and it also worked as normal. Is it possible that RPM is missing some dependencies?

Steps to reproduce:

  • Install Blender from RPM
  • Run it, and go to Preference ->Add-ons
  • It should show that add-ons are missing
  • Additionally you can check in context menu if you can import fbx for example.
1 Like

It was a packaging error (due to upstream changes?). It will be fixed in 3.5.0-3 which is currently in testing.

If you need to use Blender 3.5 now, you can install the update from testing following the instructions on that page. Giving feedback on Bodhi will also help this update be pushed to F38 stable sooner.

Otherwise, you could downgrade to Blender 3.4.1:

dnf downgrade blender
1 Like