Best way to install virt-manager

Hey everyone,

Whats currently the best way to install virt-manager. Tried to use the container method as described here: Overlaying libvirt on Silverblue / Kinoite / Sericea / Onyx and CoreOS

But when launching virt-manager I get errors about missing socket:

Failed to connect socket to '/var/run/libvirt/virtqemud-sock': No such file or directory

Also tried to use the podman machine but there seems to not be a qemu-system-x86 already in the default image, no luck there also.

Is layering still the best option ?

1 Like

Looks like it is. You can also take a look at Overlaying libvirt on Silverblue / Kinoite / Sericea / Onyx and CoreOS.

Layering it then. (the link you provided I already saw, and also mentioned it in the post).

Wouldn’t mind using gnome boxes interface, but their flatpak doesn’t allow for ssh and usb redirection which I use a lot .

Sorry, my mistake, I meant this answer from the thread, but you’ve probably already seen it.

I just do this:

distrobox enter Fedora39
sudo dnf install -y virt-manager
distrobox export --app virt-manager

rpm-ostree update --install qemu --install qemu-kvm

Maybe you still need to use an ssh connection to libvirt. This at least saves all the GUI viewer layering.

Libvirt in Distrobox

Have a look at this. I tried it, you need a rootful box for libvirt so that it starts automatically. I think it is not worth it, unless your system breaks. So I just layer virt-manager qemu qemu-kvm and it just works.

This is the best way I have found. But you need distrobox.

If you need a root container ( and one with it’s own processes ) You can use systemd-nspawn .

1 Like