Battery replaced cause weird problem

I’ve replaced the battery of my laptop, the battery is working without any problem after I boot Fedora, I can remove the AC cable , everything is ok, battery is discharging, charging, all good. What is the weird thing… I can only Boot into Fedora if I have the AC cable plugged in, if I remove it, the laptop shuts down. If I boot into Fedora and remove AC cable , battery is working without problem… any suggestions…

Welcome to the community @mirevsky

What kind of Laptop do you use? First thing i would try is to see if there is a new firmware for your laptop.

Please have also a look to the #start-here section to get an idea what kind of info’s we need to help you.

I actually just solved the problem :slight_smile: sudo dnf reinstall grub2-efi grub2-pc grub2-pc-modules grub2-tools-efi grub2-tools-extra shim did the trick :slight_smile: I have Alienware m17 and originally I had 60WHr battery , replaced it with 90WHr one… and noticed the problem…

I celebrated too soon :frowning:

@ilikelinux I just installed Clear Linux to test if this is only issue with Fedora, and booted without any problem, now checking Suse. Please let me know what kind of details you need to resolve the problem.

As you are testing with different Distributions, if you can also test different Fedora version, it will also give us more hints.

Like Fedora 33, 34, 35 (rawhide).

Does this issue occur when you are booting the LiveUSB as well?

There is no issue with Fedora Live Usb, and I’ve not tested Fedora 33 and Fedora 35. I’ll test and get back to you. But I can confirm that Suse is fine, too.

1 Like

@sampsonf I can confirm this problem is only with Fedora 34, I’ve tested Fedora 33 and Fedora 35, I’m currently on Fedora 35 and no problem.

1 Like

Are you writing down the Kernel-versions from your other distro’s you check? With Fedora you can check different kernel versions too (like @sampsonf mentioned).

Hardware information, Kernel version etc. Here a big list for that:

I do like inxi -Fzx who gives you a good overview of your system.

1 Like

When you try with Fedora 34, have you done a full system update by sudo dnf upgrade?

yes, I’ve been doing update and upgrade constantly, every day on Fedora 34. I also did fresh install on Fedora 34 and I had the same problem. Fedora 35 , all good, not even one bug. In Fedora 34 I was getting like bugs and crushes when kernel is upgraded… since I installed Fedora 35 , and no bugs, don’t want to go back to 34 :smiley:

1 Like

Does your machine has the latest system firmware?

Yes, that is the first thing I did, when I noticed the problem.

@sampsonf @ilikelinux I can share my laptop hardware details
inxi -Fzx

This problem is only when I replaced the 60WHr battery to 90WHr in Fedora 34.

I find a similar topic in Dell Forum.

You might want to post your question over there.

Also, you can see if the dis_ucode_ldr kernel parameter is helpful to your case or not.

1 Like

@sampsonf thanks the command worked perfect on Fedora34, I even tested Arch Linux, wasn’t booting just like Fedora.
sudo grubby --update-kernel=ALL --args="dis_ucode_ldr


Good to hear that.

Please mark this thread as solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.