399 MHz on battery

When my notebook is not on the charger, the cpu clock does not exceed 399 MHz and the boot takes much longer than usual. The clock doesn’t change regardless of the power profile I use. However, when I put the charger in, the clock goes up to normal values, even if I remove the charger afterwards. I’ve been using Fedora 35 for a while now and this issue only came up recently. I read a similar issue here where disabling thermald resolved the issue. I did that and apparently the problem is solved, but I don’t think it’s the best solution. I don’t know if it was a recent thermald update that did this.

Hi, if it happen after updating the system that contain new kernel, you could try booting to older kernel for comparison in case it because newly kernel update.

You could also check from bios power management to check if there any power management control enabled and you can try by disable it. By disable the power management from the bios, hopefully it will let GNU/Linux have more control.

Related topic:


I just read again your post and missed read that you already solved the problem with disabling termald:

As @augenauf shared link above, look like it possible if it caused by thermald.