Backintime doesn't start anymore

Last week backing up worked fine with backintime in Fedora 30, si I guess it has to do with the last kernel-update. Backintime doesn’t start in the GUI anymore, and in terminal (as root) I get this:

Traceback (most recent call last):
  File "/usr/share/backintime/common/", line 27, in <module>
    import config
  File "/usr/share/backintime/common/", line 32, in <module>
    import tools
  File "/usr/share/backintime/common/", line 51, in <module>
    import dbus
ModuleNotFoundError: No module named 'dbus'

It seems the module does not exist. “Systemctl status dbus” gives this result:

● dbus-broker.service - D-Bus System Message Bus
   Loaded: loaded (/usr/lib/systemd/system/dbus-broker.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-05-21 13:25:35 CEST; 49min ago
     Docs: man:dbus-broker-launch(1)
 Main PID: 848 (dbus-broker-lau)
    Tasks: 2 (limit: 4915)
   Memory: 6.6M
   CGroup: /system.slice/dbus-broker.service
           ├─848 /usr/bin/dbus-broker-launch --scope system --audit
           └─849 dbus-broker --log 4 --controller 10 --machine-id 5fba95cdc3a7454492146e228cb218c0 --max-bytes 536870912 --max-fds 409>

But also this: dbus-broker[849]: A security policy denied :1.86 to send method call /:org.freedesktop.DBus.ObjectMana>

What version of backintime are you using? Can you please tell us the output of:

rpm -q backintime
rpm -q backintime
package backintime is not installed

[root@linux pbraet]# whereis backintime
backintime: /usr/bin/backintime /usr/share/backintime /usr/share/man/man1/backintime.1.gz

And in dnfdragora under “installed”:

backintime-common    1.2.0    3fc30   noarch
backintime-plugins       1.2.0    3fc30   noarch
backintime-qt                1.2.0    3fc30   noarch
1 Like

That is the latest version then:

The dbus python module is provided by the python3-dbus package. Could you please check if that is installed? it should be, since it’s a requirement of backintime-common, which is a requirement of backintime-qt:

$ sudo dnf repoquery --requires backintime-qt
backintime-common = 1.2.0-3.fc30

(ins)[asinha@ankur-pc  ~]$ sudo dnf repoquery --requires backintime-common
python(abi) = 3.7

The output of these commands are identical to yours, so everything should be there.
Now I found out there are two graphical links to Backintime, only one works Administration > backintime, System > backintime doesn’t work. sudo backintime -i doesn’t work. Last week everything worked, now making a new snapshot using the only working graphical link Administration > backintime failes:

Error: rsync: rsync_xal_set: lremovexattr(“/run/media/pbraet/Backup/backintime/localhost.localdomain/root/1/new_snapshot/backup/sys”,”security.selinux”)
failed: Permission denied (13)

And from journalctl -r

python3[9293]: backintime (root/1): INFO: Unlock

python3[9293]: backintime (root/1): ERROR: Failed to take snapshot !!!

python3[9293]: backintime (root/1): WARNING: CONTINUE: returns 24

python3[9293]: backintime (root/1): WARNING: Command "rsync --recursive --times --devices --specials --hard-links --human-readable --links --acls --xattrs --perms --executability --group --owner --info=progress2 --no-inc-recursive --delete --delete-excluded -v -i --out-format=BACKINTIME:%i %n%L --link-dest=../../20190517-072909-166/backup --chmod=Du+wx --exclude=/run/media/pbraet/Backup --exclude=/root/.local/share/backintime --exclude=.local/share/backintime/mnt --exclude=.gvfs --exclude=.cache/*--exclude=.thumbnails* --exclude=[Tt]rash* --exclude=*.backup* --exclude=*~ --exclude=.dropbox* --exclude=/proc/* --exclude=/sys/*--exclude=/dev/* --exclude=/run/* --exclude=/etc/mtab --exclude=/var/cache/apt/archives/*.deb --exclude=lost+found/* --exclude=/tmp/* --exclude=/var/tmp/* --exclude=/var/backups/* --exclude=.Private --exclude=/home/pbraet/Backup --include=/ --include=/** --exclude=* / /run/media/pbraet/Backup/backintime/localhost.localdomain/root/1/new_snapshot/backup

I think it is a bug in the new kernel, at every startup I get an error from abrt, wanted to file a bug report this morning but there are a bunch of duplicates already! This morning it was dnfdragora, it is every day something else that crashes, but it is always from abrt:

python3.7 killed by SIGABRT

Guess this will be the cause, I’ll try booting from an older kernel version and see what happens. No booting from kernel 5.0.13 didn’t work, the same failure. I hope Fedora can fix all these bugs, because there are many in Fedora 30. fc29 was much more stable.

I just installed backintime. One appears to be for a non root user, and the other for root user. Hence two launchers. (The root one brings up a dialog requesting the sudo password here). I confirmed this by running:

$ rpmls backintime-qt | grep desk
-rw-r--r--  /usr/share/applications/backintime-qt-root.desktop
-rw-r--r--  /usr/share/applications/backintime-qt.desktop

This particular error from rsync is listed in man rsync:

24     Partial transfer due to vanished source files

I’ve never run into it myself, but if the backup includes systemfiles which were removed by the system during a backup, this could happen I guess :thinking:

Maybe. Although, we’re yet to see any information that suggests so.

Ah—can you provide the link to one of these please?

The maintainer hasn’t had a chance to look at this yet. If you are seeing this regularly, please comment on the bug asking them to increase the priority of this one.

But this is related to dnfdragora. How does this make backintime fail?

That depends on where the bugs are. If the bugs are in the software, Fedora can’t fix them—Fedora doesn’t develop this software. It merely packages it up to provide to users (Fedora is downstream).

No, my commands only list the requirements, they don’t check for them. Please run these commands and provide us the output:

sudo dnf install python3-dbus

rpm -qa \*dbus\*

Thank you. It is not what we thought, it is the config files. I believed Backintime is a GUI, so for the normal user but it is not: this program is for experts. I am still looking for a simple backup tool to make a full system backup, su no deja-dup (only home folder) and no backintime (too complicated). Just one click and a full system backup. Does such a tool exist for Linux?Screenshot_2019-05-24_09-27-42

I thought so, because it kills Python3

There must be. I only back up my home folder (and keep a separate /home partition) and if something breaks it takes me less time to reinstall, mount the /home partition and get back to work than it would to copy over a full system backup. So, deja-dup works for me in this use case.

What is your use case? Why the full system backup?

There’s this post about another backup tool:

It seems “full system backups” is treated as an advanced use case and therefore has a few highly configurable but not very user-friendly tools to carry out. /home backups, on the other hand, seem to be the “simple” end-user case and therefore have GUI tools to carry out.

Have you tried running deja-dup as root (using sudo)? Maybe that’ll work?

Because I also install other applications on Fedora, so it would be less work to have a full system backup to avoid reinstalling everything. I already use deja-dup to backup /home and NextCloud for my personal files. Thank you for the tip.

1 Like