[logs now available] Anaconda DBus modules fail to start on time


#1

Edit: I must have missed something while scanning through the logs. In dbus.log I get

dbus-daemon[1590]: Activated service 'org.fedoraproject.Anaconda.Modules.Network' failed: Process org.fedoraproject.Anaconda.Modules.Network exited with status 1
dbus-daemon[1590]: Reloaded configuration

I haven’t found any fixes when researching this yet.

Edit again: There’s no anaconda-ks.cfg around anywhere, I’m not sure if that’s an issue or not.


Hello,

I admit I’m new to Silverblue. Anaconda seems to start properly:

Starting installer, one moment...
anaconda 29.24.3-1.fc29 for Fedora 29 (pre-release) started.

* installation log files are stored in /tmp during the installation
* shell is available on TTY2
* when reporting a bug add logs from /tmp as separate text/plain attachments

On the log tab I get lots of these:

INF startup_utils: Waiting 600 sec for modules to be started.
INF startup_utils: Waiting 599 sec for modules to be started.
INF startup_utils: Waiting 598 sec for modules to be started.

and so on until it times out:

Anaconda DBus modules failed to start on time.

The odd thing is, I don’t time out when using the exact same .iso file in a VM.

Possible relevant links are here because I’m not allowed to put all of them in this post.


I doubt it’s because my PC is too slow because if so, then the VM shouldn’t have even become close to working, and also, I don’t think my PC is that bad. I’ve got a Ryzen 3 1300X, 8 GB of RAM… (full list at https://pcpartpicker.com/list/cCxFHh)


#2

There are some other logs here as well as information on how to access them. Maybe one of those will offer more info?


#3

I’m sorry, it’s taken me a little while to get the logs. But here they are. :smiley:

https://drive.google.com/file/d/1YDaZLzzHgafmHxq-hwme3ZVEItwj7JqC/view?usp=sharing

Edit: I’ll also look into those other logs.
Edit again: It appears that I’m stuck in text mode installation. I boot into tmux and the graphical stuff never even shows up. Most of the logs there seem to be the same as the log files attached above. I am using UEFI, I could try it from BIOS as well.


#4

Hmm, looks like a NetworkManager issue:

14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:Traceback (most recent call last):
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:  File "/usr/lib64/python3.7/runpy.py", line 193, in _run_module_as_main
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:    "__main__", mod_spec)
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:  File "/usr/lib64/python3.7/runpy.py", line 85, in _run_code
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:    exec(code, run_globals)
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:  File "/usr/lib64/python3.7/site-packages/pyanaconda/modules/network/__main__.py", line 5, in <module>
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:    network_module = NetworkModule()
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:  File "/usr/lib64/python3.7/site-packages/pyanaconda/modules/network/network.py", line 59, in __init__
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:    nm_client = NM.Client.new(None)
14:04:03,570 WARNING org.fedoraproject.Anaconda.Modules.Network:gi.repository.GLib.Error: g-io-error-quark: Timeout was reached (24)

It’s failing to connect to NetworkManager, though I have no clue why…


#5

Do I have to put firmware and/or drivers onto the image? My wifi dongle has a reputation for not liking to behave.


#6

What if you complete the installation without the dongle or networking, then set it up afterwards?


#7

I recall seeing something like this when a broken version of dbus landed in F29 updates-testing. Since dbus never started, it impacted NetworkManager starting successfully too.

https://bugzilla.redhat.com/show_bug.cgi?id=1623781

Hard to say for sure it is the same issue, but I’m just throwing out ideas.


#8

Thanks for the advice. I’ve got Silverblue up and running, but not the wi-fi…I don’t suppose there are any Broadcom drivers on Flathub?

Normally I’d try to get ethernet running, but I broke my motherboard’s ethernet port a while back.

If it’s any help, GNOME Control Center says

Connection failed - Secrets were required, but not provided

#9

Broadcom drivers are available from the RPMFusion repo. Since you can’t really get the repo without internet access, you can grab the rpm from here, save it to a USB, and install it on the system via rpm-ostree install path-to-broadcom-wl.rpm. Then you can properly add RPMFusion to ensure it stays updated.


#10

Thank you for the response, I’m running rpm-ostree with the -C flag because of no wifi connection. It goes something like this:

broadcom-wl requires kmod-wl which requires akmod-wl which requires kmodtool and akmods. akmods requires rpmdev-vercmp…

Should I keep going along the dependency list or is there a faster way to do this? :laughing:


#11

Hmm, if you have another working system where you can run Fedora Workstation 29 (the live CD should also work) with networking, you can install RPMFusion and then run dnf download --resolve broadcom-wl to download all the needed rpms into the current directory. Then you can transfer them to the USB and install them all at once (rpm-ostree install *.rpm or similar).


#12

Everything went smoothly until I tried

rpm-ostree install *.rpm

The only ouput was:

error: the connection is closed

It looks like somebody else had this issue here: https://pagure.io/teamsilverblue/issue/37#comment-530890

Here is the output of journalctl | grep rpm-ostree, I’m not sure if that helps though.

https://drive.google.com/open?id=1_lqzOFfYmgWphlqyHqVRBMt-5PMYydm9


Edit: Maybe it’s a dconf error? https://github.com/ansible/ansible/issues/47909


#13

Well, typical wifi adapter. After stubbornly turning it on again, it decided to start working. I’m going to get the drivers installed now with the hopes that it will work next time I boot up.


#14

Hmm, based on that issue, dnf download probably just downloaded too much and rpm-ostree is freaking out over a base package replacement…

Can you:

  • Show the file names of the packages that are being installed. I can see if there’s anything in the Silverblue base image.
  • Run journalctl -u rpm-ostreed -b immediately after the error occurs, which should show all the logs from rpm-ostreed in the current boot, and upload the output.

#15

We seem to have posted at nearly the exact same time. In case you didn’t see it, my wi-fi dongle randomly started working again and I now have internet access on my machine. Should I still continue with the steps you told me or should I just add RPMFusion and install broadcom-wl?

Installing the drivers might make it more reliable, and hopefully it would work the next time I boot up (rather than if I did nothing)…

Also thank you very much for your help. =)


#16

Haha, I didn’t even notice.

If it’s working perfectly now, it’s your choice. That being said, you can always try installing RPMFusion (you might end up using this for other stuff anyway) + the broadcom-wl package and see how it goes. Since this is Silverblue, if it makes things worse you can just reboot and select the old deployment.


#17

This is probably a bit of a stupid question but how do I install RPMFusion? Their website says to run

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

but since dnf isn’t a thing on Silverblue, I changed it to

sudo rpm-ostree install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

and it says

Downloading 'https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-29.noarch.rpm'... done!
Downloading 'https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-29.noarch.rpm'... done!
error: Package 'rpmfusion-free-release-29-1.noarch' is already layered

#18

Just looks like the free one is already installed. Try just installing the nonfree one (i.e. removing the URL for the one just labeled “free”).


#19

Thanks. Do I need to run rpm-ostree differently? I’m running

rpm-ostree install broadcom-wl

and it’s complaining about not being able to find it…

Checking out tree d18df00... done
Enabled rpm-md repositories: fedora updates
rpm-md repo 'fedora' (cached); generated: 2018-10-28 11:00:54
rpm-md repo 'updates' (cached); generated: 2018-11-01 15:02:07
Importing metadata [=============] 100%
error: Packages not found: broadcom-wl

#20

You have to reboot for the new repo to be installed to /etc.