Automatic screen lock stopped working with Fedora 32

Since I upgraded to F32 I cannot rely on the automatic screen lock. Sometimes after reboot it seems to work for some period, but then it stops. Just now I went out for a walk for cca 15 minutes and when I came back my screen was still how I left. This happened a number of times already since the upgrade. The worst was when I suspended the machine and it came back unlocked when I resumed.

This is quite concerning from a security point of view, does anyone have similar issues and have any ideas on how to fix it perhaps?

My settings:


It generally implies that something is inhibiting the screen lock. Do you have any extensions installed?

The first thing to do would be to create a new user and see if the issue persists there. That tells us if it’s a bug in Gnome or something to do with your user configuration/extensions/etc.

1 Like

Hi, yes, I have some extensions, but they were installed before on F31 as well without this problem. I have now disabled all extensions, but still have the same issue. I also tried creating a new account, where I don’t have anything, after a short testing I couldn’t reproduce the issue. I am not sure if this is some bug triggered by something in my user profile or something else got messed up during the upgrade. I am planning to do a clean install at some point, but I was hoping there is some way I can fix this in the meantime.
Do you happen to know if there are any logs related to the screen lock somewhere?

1 Like

Take a look here:

If the new user didn’t have the issue, then yes, it indicates it’s related to your user configuration (and that it isn’t an upgrade issue: the upgrade does not touch your user configuration).
Extensions need to be updated when a new version of Gnome is released—initially there were quite a few that did not work correctly on the new Gnome 3.36 that Fedora 32 has because their developers had not updated them. So the standard check is always to turn them off to see if that fixes things.

Hopefully the logs will show what is inhibiting the lock. I know that lots of apps inhibit it, so maybe it’s one of those.

1 Like

Thanks, there are unfortunately no logs when the lock should trigger.
Indeed, I remember updating extensions and some of them were broken and remained disabled. I have disabled all extensions now, so they should not interfere anymore, but didn’t help. I can’t recall changing any configuration apart from upgrading to F32 when this started, I must have some weird setup if I am the only one facing this.
For now i just need to remember to always lock it manually, at least until I can figure out what is causing it or do a clean install…

1 Like

Perhaps take a look at dconf-editor to see if any power related settings are not set to default values? Any apps that may be inhibiting this? (Even some media players inhibit these things sometimes)


Yes, I did check the gsettings all seem to be correct (after boot everything works fine for a while). I now updated and restarted without any extensions, so far it is working, but it’s only a couple of hours yet, usually it stops working after longer time. I will keep an eye on what apps I start now and see if any of them might be the cause.

1 Like

Sorry, I forgot about this thread. Since then I have reinstalled F32 on my machine from scratch and so far I don’t see this issue anymore. Thanks for the pointers, I think it was either some extension or a messed up configuration.

1 Like

Hi there. Glad to hear you fixed it finally. I’m facing the same issue. Currently I’m under the impression that my screen will not lock when I’m using an external screen, but I’ll need to test that again.

I did check settings in Gnome settings, and in dconf-editor as well.

Did you wipe your home when reinstalling Fedora 32? If not, am I wrong to assume that it’s not related to user profile after all?

Hi Andy, I did a complete wipe, when I reinstalled, so cannot rule out something in my profile. I also had a few Gnome extensions installed, but simply disabling them didn’t help, so I was very careful when adding extensions on the new install, so far I haven’t noticed the same issue yet.

Just an update, this happened to me again now on F32. It actually happened twice, in both cases there was a notification shown that never got cleared, once it was a new email notification from Evolution the second time it was new software installed notification. The popup was never closed and remained shown and the screen did not lock.

I tested this now again, now it happend without any notification.
I have an external screen connected via HDMI which is the primary screen, both screens (laptop + primary) remain on, screen lock not working and monitor sleep never happens either.

For me it’s clear now that it’s not related to an external screen, but that a restart is fixing it for a while.

I noticed that if I want to force a reboot, oftentimes Firefox is blocking the restart due to audio playing somewhere. Maybe that same block will lead to the screen not being automatically locked?

Just now I left my laptop on for a while and I noticed the screen going blank, even with an Evolution notification displayed, so it seems it works occasionally even without restarts in between.
I also think it might be some application that occasionally inhibits the lock. I almost always have Evolution and Firefox running, and I also noticed the thing with Firefox playing audio when trying to reboot even if there is no sound produced.

I suggest concerning this issue to contact the GNOME developer team for further assistance, because they know the most about their project and they can repair it if it’s a bug. :grinning: