Authentication always required after boot

this dialogue box started appearing right as the OS loads, every time after it boots.

it supposedly started when I disabled secureboot, in order to successfully install Nvidia drivers, as per the recommendation from another thread, that solved the previous issue.

when the system boots this is the first thing that I see, I can see the desktop dimmed in the background but cannot do anything before I enter the password. this isn’t the lock screen. I disabled the lockscreen by enabling automatic login. before that, every time I booted the system, I’d get straight to the desktop environment password free and be able to start working. I suspect that this is the passkey I set when I disabled the secureboot. though I can’t be sure as it’s the same password I set to my OS and may be mixing things up it’s just an knowledgeable suggestion.


  • OS: Fedora Workstation 39.
    I am dual booting, Fedora is running on a separate hard drives from Windows.
  • system: PC: Dell XPS 8930

thanks a lot for all the helpers!

If you set a password at the same time as disabling secure boot then it is probably a boot password within bios. If that is the case then simply enter the bios again and remove the password there.

Most do not ever set a password within bios and bios passwords must be entered before the OS even begins to load.

thanks for your reply :slight_smile:

I see what you mean. I don’t recall setting a password using the BIOS. I did set a password in the Terminal when I followed the first step (mentioned below):

one of them was setting a key. I used the same password I set for the OS when I first installed it. as I proceeded with the instructions and booted the system. I wonder if this was when I unintentionally set this password.

enabling and disabling secure boot is done within the bios setup menu, and at that point there is usually 2 password options. One for administering the bios which will require the password before entering the setup menu and the second for booting which will require the password before the machine can be booted into the OS.

enrolling the key from mokutil is not the same since it never enters the actual setup menu but only thru the blue MOK Management screen given during that boot for actually importing the key into the bios.
The password given when performing that command during import of the key is only for use as the final step to actually complete the import.

1 Like

Make sure the keyring and login passwords are synchronized:
Keyring Authentication required prompt every login - #2 by vgaetera
If automatic login is enabled, set an empty password on the keyring.


I see. so I remember now that when I was following the mokutil steps, and rebooted my system so that the MOK Manager will be launch, I was requested to fill in a password and I filled in the same password I set for my OS. I didn’t know I could simply leave it blank.

do I follow the mokutil steps again for MOK to be launched upon restart? would it affect the Nvidia drivers in anyway?

just to be sure, this isn’t the step the password was created right? because that was through the Terminal not the BIOS.

thanks for the tip!

it took me some tinkering but I managed to install the Passwords and Keys app.
under the login page, which one is it that I should delete the password for? btw, I don’t see an option to change the password, only a delete button.

Right click the “Login” keyring.

1 Like

Jeff! It is clearly not a UEFI (uefi setup) password, since they are in the OS. If there was a BIOS password set, the windows would be before boot and not in Linux. It clearly states the keyring password as well.