Audio problems with minecraft 1.19.4

Hello! new ish fedora user here! I am trying to get audio working on Minecraft in order to play with some of my friends on their realm. Right now I don’t have a headset, so I am using airpods pros 2 for audio, on older versions of Minecraft I seem to have no problem with audio on Minecraft (1.12.2 being the older Minecraft version) in minecraft I have 2 options for audio, “System default” and “JACK default”

I have tried:

  • going into the audio manager and setting it manually
  • switching java versions (from openjdk 17 to openjdk 8)
  • restarting the computer and minecraft itself
  • restarting my airpods
  • looking elsewhere for solutions

Minecraft instance information

  • 1.19.4 running Fabric
  • mods used: fabric api 0.80.0, optifabric 1.13.24, optifine 1.19.4,

I have the same issue. What I have found is that connecting headphones or a speaker to the audio jack on your PC will work fine. It’s something about wireless bluetooth audio that minecraft seems to have an issue with.

I also found this solution. Have you tried this?