ASUSTek AC1200 wifi dongle, anyway to make it work?

I recently replaced some parts in my desktop to get it working again, so I decided to install Silverblue on it. Been running it on my laptop for a while and I love it!

Problem is, the way things are laid out currently I can’t really get it hooked up to Ethernet and there is no built in wifi currently. I have an Asus AC1200 wifi dongle (shows up in lsusb as ASUSTek Computer, Inc. 802.11ac NIC) and was trying to make it work, but no success so far. I’ve tried installing b43-firmware and kmod-wl, not sure if either one would’ve worked but they were the only option I found that would work with Silverblue’s immutable OS.

For now I can get Internet on that machine by plugging in my laptop with an ethernet cord and sharing its wifi, but this is not ideal. Is there any way to make the dongle work or should I just look into buying an PCI wifi card that will work out of the box?

There are a couple of different ASUS dongles that match AC1200, could you try to get some more info, maybe a physical description?

If it’s the USB-AC53 nano, then that seems to use the RTL8812BU chipset. There are two driver options, rtl88x2bu and rtl8822bu (former seems to be better), and unfortunately of them are available packaged for Fedora.

If you really want to get it to work you could maybe take a look at creating akmods, e.g. the Broadcom spec file (most of it is just patching and changelogs), but tbh it would probably be easiest to just get another dongle.

If I’m gonna buy something else it’ll probably just be a PCI wireless card anyway at this point, which I’ll be able to do more research on since I would have to order one online. I’ll look into the akmods first though. Anything to save a little money :wink: Thanks for your help!