Any way of doing a standalone UEFI installation still?

Been waiting since the M2 Pro Mac mini was released to install Asahi Linux. It’s great to see how much work has gone into it!

I noticed a couple of guides on installing Asahi make mention of a “UEFI environment only” option which no longer seems to be present in the installer. In particular, I’m trying to install NixOS, since it’s my preferred distro and has been for a few years now, and the installation guide for the Asahi-based offshoot specifies to use that option.

  1. Was the option removed?
  2. If so, I’m curious as to why? But particularly, will it be added back, and when? I’ve been quite excited for this release and being able to finally install Linux after nearly a year in the making, so seeing the one option that I need be suddenly removed is a somewhat disconcerting, especially when I can’t seem to find any other information regarding it.
  3. If it was removed and won’t be added back, how would a person go about installing a non-Fedora linux distro (such as NixOS in my case) instead? My initial assumption was that the installer script sets up the UEFI environment automatically or something now, but that doesn’t seem to be the case, as rebooting just takes me straight back into MacOS. Would a person just do a Fedora install and then overwrite that with a separate distro? Is there a safe way to do that? Is the space the installer allocates to that install relevant when overwriting the distro, or would I, for example, need to specify ‘max’ in the installer if I wanted NixOS to consume the entire available storage?
  4. If it wasn’t removed, how would I go about accessing it?

Any help or information would be appreciated :3
Thanks again to the Asahi Linux team for all your heard work!!!

The option is still available in expert mode (EXPERT=1 sh), but we’ve temporarily hidden it because that image is built off of the Arch Linux ARM build process, and that is on hold pending ALARM updates and time. The old existing images do not support M2-series desktops, so it would be confusing to have an option available that is broken on some machines. Sorry for the confusion.

We’re already talking about how to migrate those images to derive from the Fedora image build process, so we no longer depend on the ALARM build scripts for that. When that is done or when the ALARM updates can go through (January probably), whichever comes first, the option will be back.

The quick hack right now (to avoid using the outdated ALARM-based build) would be to just do a Fedora Minimal install, then force a USB boot from the u-boot console and, as part of your install process for your preferred distro (NixOS/etc), just delete the Fedora partitions and Fedora bootloader from the ESP. That is, effectively, just a more roundabout way of getting a Fedora-based build of the UEFI startup stuff. Only amusing thing is you’ll get the Fedora logo for m1n1 stage 2 :slight_smile:

1 Like

Actually, you know what, I think I can cook up another Arch-based UEFI image without too much fuss (I only need to make sure m1n1/u-boot are up to date and they don’t have to be pushed to users, just our dev repo). Let me do that real quick.

1 Like

Should be available in our dev installer now:

curl -L | sh

Please try it and I’ll promote it to production if it works :slight_smile:


Oh geeze. You really didn’t have to go through all of that work. Would’ve been happy with the first solution.

But it worked! The I managed to succesfully install NixOS. Thanks for all your help!

I keep getting a message printed to the console ieee80211 phy0: brcmf_escan_timeout: timer expired both in the live image and the installation. I presume it’s an issue with the NixOS spinoff project, but I wanted to check and see if this is expected and/or common behaviour with Asahi related stuff generally just in case.

Really appreciate the help Marcan, and kind regards to all those working at the Asahi team! You all do some really amazing stuff :3

1 Like

Some spam from brcmfmac is not unexpected. Assuming WiFi works anyway, just change your console loglevel to hide them. That driver is… quite a mess and we’re making major changes to improve it, so cleaning up warnings isn’t a major prio right now since users won’t normally see them (in graphical setups etc).

1 Like