At the end of my rope with my M1 Mac with Asahi linux

Hi,

I am at the end of my rope with my M1 Mac with Asahi Linux.

I wanted a Mac running linux. My son-in-law strongly recommended M1 and we were both unaware that only one distribution can run with an M1 Mac. I installed Asahi retaining a partition for Mac OS.

A few months ago, I attempted to go into the Mac OS partition. It failed to do so. Regrettably, in my state of alarm, I erased the Asahi partition, in the hope that it would help solve the problem. It did not. Being remote from any Apple shop, Apple told me the charge for them to receive it upon delivery is $650 (!!!).

Apple phone support could not help. Attempted Mac OS install from a usb stick failed. I shipped the computer to my brother so he could give it to an Apple shop in his vicinity. They could not repair it. They said that they were unable to repartition the disk because Asahi linux used an encrypted partition.

Now, I am aware the root problem may be hardware. Regardless, the unit is fully non-functional in its present state.

I am even open to shipping it to an Asahi expert to see if anything can be done.

I seem to be pretty much out of options with my cost being an M1 Mac machine that I bought used and used for perhaps 3 months total.

If anyone has any advice, I am all ears!

Hi Tony! Sorry that you’re dealing with this.

I think these instructions from Apple apply to your situation. You would only need access to another Mac running macOS Monterey or later, and a cable to connect them.

1 Like

Wait, you mean it doesnt even respond to your pressing the power button?
I was hoping you could lend a mac from someone and creat a macos intallation media and reinstall macos.
Shit, I think I won’t intall Asashi on my MBP now. The risk is too big.

1 Like

What does currently still work on the system? Does it boot into recovery when you start the Macbook and keep the power button pressed? If not please describe what happens exactly on power-on?
Do you still remember how and which partitions you erased? How did the behavior change after erasing the partitions?
The report from the Apple shop doesn’t make much sense. Depending on what you have deleted either a Revive over DFU (which would keep data on the SSD) or DFU restore (wipe the Mac clean) would have worked.

1 Like

Have you looked at the link posted by @aratuk? Do you not have access to the 2nd mac and a suitable cable? You might need to seek the help of a nearby Apple enthusiast. Even if you have the necessary hardware, it is good to have an experienced user looking over your shoulder when doing such things for the first time.

1 Like

Hi aratuk!

I live in a very remote area and cannot do so myself. I shipped it to my brother. I do not know if he did that but i know he tried to reinstall Mac OS from a stick.

After this failed, my brother took it into an Apple-recommended shop and they could not get it to work. I’d be shocked if they did not try your recommended procedure but do not know for sure.

Thanks!

Oh, it powers up. Heck I just powered it up since getting it back from my brother, Now, the display is an exclamation mark in the center of the screen and on the bottom, the following text:

Apple Support

If your Mac starts up to an exclamation point in a circle - Apple Support

The firmware of your Mac needs to be revived.

Oh - wait!

support . apple . com/mac/restore

I don’t even get the recovery menu.

I think I’m screwed.

It may be a hardware issue. I don’t know.

Thanks!

Right now, nothing works.

"Does it boot into recovery when you start the Macbook and keep the power button pressed? If not please describe what happens exactly on power-on?

What I share above. An exclamation point and the link - support . apple . com/mac/restore

“Do you still remember how and which partitions you erased? How did the behavior change after erasing the partitions?”

It was one of the four options in the Apple recovery menu - disk something I think. Nah, the behavior did not change. Still could not get into Mac OS and the reinstalls did not get past the preparing stage.

Thanks!

I do appreciate that I may be suffering a hardware issue. No idea, really.

Thanks.

There is no one local. I live in a very rural area of South Dakota. The “big city”, Aberdeen, population 15,000, is 55 miles away.

That is why I shipped it to my brother (in Massachusetts).

I think my final hope is to ship it to some expert and let him/her do what he can.

I’m not sure this is a hardware issue. It could be that the system recovery partition is missing. The paired recovery OS for the Asahi install went missing you deleted that partition. It’s impossible to say when or how both happened but I believe a DFU revive (possible keeping data) or DFU restore (clean device) will recover the macbook.
I would have expected that the Apple recommended shop would be able to do that. I’m not sure what they tried but their report about the encrypted partition doesn’t make much sense to me.
The DFU revive/restore would be easy with a second Mac but I gather none is available.
I’m not sure if I can recommend this but idevicerestore is can be used to restore from a PC. The latest release is too old but the version in fedora should be usable.
Disclaimer: I haven’t used the fedora package and my last use of idevicerestore was ~2 years ago?

1 Like

DFU, has a step now that requires the username/password of the machine owner in order to wipe it. I learned all this not to long ago, after uh, my own adventure with asahi.

But, yes what I learned in all that process its its pretty hard to brick an M1 if you have access to another mac to perform the DFU process, but even then I’ve got a fair bit of experience with low level stuff and it still took me a couple tries to get everything working again.

1 Like

Nobody has ever destroyed a Mac using Asahi Linux*. The worst that can happen if you manually mess with disk partitions is that the Mac boots to a “please recover me” screen. If that happens, you can always recover using the DFU process mentioned above and another Mac.

We have enough users (thousands) that, statistically, at least a few are going to have their computers randomly break after installing or while using Asahi for completely unrelated reasons. Please don’t take single reports of trouble as an indicator that anything is wrong with Asahi.

* Other than that time I destroyed my speakers, which is why we spent almost a year after that making sure the whole speaker safety mechanism was rock solid and that couldn’t possibly happen to anyone once we officially released speaker support.

3 Likes

First, try two things.

  1. From a fully powered off state (screen black), press and hold the power button. Do you get the recovery menu or the exclamation point screen?
  2. From a fully powered off state again, press, release, then press and hold the power button (do this quickly, like within half a second or faster). Does this result in a different outcome?

If both of those get you the exclamation point screen, it sounds like your machine just needs a DFU restore. You do not need any kind of functional recovery menu for that to work. Follow these instructions carefully (you will need another Mac and a USB cable to connect them, the other Mac can be Intel). When you boot into DFU mode, the screen will in fact show nothing (it will remain black, if you see the exclamation point screen you didn’t do it right and it won’t work!). Once you begin the DFU process via USB from the other machine, the screen will light up and show a progress bar.

Reinstalling macOS from a stick does not work for Apple Silicon machines. The boot system is completely different to Intel. You need to follow the DFU process above to do a full wipe/reinstall on these machines. It’s very different to PCs and older Intel Macs.

Apple store technicians should be trained on how to do the DFU restore and will do it for free if you ask. I don’t know about third party “authorized” shops, it’s possible they are poorly trained and do not know about this procedure. You could always point them at that support page and ask them to do it, or ask to borrow a machine from them and do it yourself. At no point should you pay any money for the repair beyond a token labor fee at most. Your machine is fine and doesn’t need any parts replacements most likely, if someone claims otherwise without trying a DFU restore correctly first, they are likely trying to scam you.

Needless to say the “encrypted partition” story is complete BS (we don’t even support encryption yet, not that it would make a difference!). Next time it might be best to not even mention Asahi, as some unscrupulous (or incompetent) tech could use that as an excuse not to fix your machine. They can’t tell whether you installed it anyway, if your machine won’t boot and it needs a DFU restore that will wipe the entire storage anyway. It literally does not matter what Asahi did or did not do at that point, the entire process was designed by Apple to be able to recover your machine regardless of the state of the internal storage and most firmware, by just wiping everything clean and installing the latest version of the OS from scratch - it quite literally formats the entire SSD storage at a low level. It is extremely robust and well designed. You would have to have an actual hardware fault for it to fail.

5 Likes

Thanks so much everybody. I am unable to address this now due to other demands, but I really appreciate your inputs.

I need to add one really important piece of information. The exclamation point menu occurred for the first time after I got my unit back. These are the displays I had from which I, my brother, and the computer shop were unable to get it back on track.

m1_screen1
screen_2

That’s really unfortunate, because you definitely would’ve been able to fix it without another Mac if you at least had a working recovery menu like that. Typically you’d use diskutil (from the command line) to make sure the partitions are in order, perhaps wipe+recreate the macOS volume, then do a reinstall.

Once you’re at the exclamation point screen (not sure how they managed to cause that…), if the power button sequences don’t work, your only option is DFU restore from another Mac. So it really sounds like the tech that was supposed to fix your Mac just screwed it up further…

Thanks everyone. It has not been functional for over four months now.

I think my only option left is to send it to an “expert” for services rendered. Or worst case, just keep it.

I won’t be any the worse off!

If you’ve access to another mac, just try DFU restore yourself. We did it a while ago for a mac which almost didn’t turn-on at all, and it worked at the end.

1 Like

Computer repair shops (like auto dealers) often flounder with novel problems – charging exorbitant prices while making problems worse.

Your best bet is to search for a nearby mac enthusiast. You may want high-end cable like the Apple Thunderbolt 3 (USB-C) Cable. Schools and groups like 4-H often have computer activities and may know of a local mac enthusiast (who may have the required cable). Trade school computer programs might help, and many would be interested in getting a donation of an M1 Mac.

1 Like

Thunderbolt cables are not required (and could even cause more issues). DFU only uses USB2 so it will work with almost any cable. You an also use an A-to-C cable as long as the C (device) side goes to the target Mac to be restored.

2 Likes

Hey Joe. I got a M2 air and wound up in the same situation you are in with your laptop. All I got was an exclamation point with a link to apple support for restoring the device.

You’re going to need someone with a mac, any will do, and connect it to yours with a USBC cable. Make sure you’re using the port closer to the screen. Hook both machines up to power so they’re charging.

Download Apple Configurator from the app store on the working mac, and boot it up. After that you’re going to have to struggle with the key combinations needed to enter DFU mode. Control and option on the left side of the keyboard, RIGHT side shift and the power button. Hold all of them down for around 10 seconds. It’s hard to get the timing right and you will have to try this multiple times.

You’re going to get prompts on the working mac to give access and connect, accept all of these requests as they appear. If you’ve done things correctly you should see a big square on the configurator app, right click on that and restore your mac. When you’re done you’ll be right back to the setup screen.

Definitely don’t need to pay a king’s ransom to get your laptop working again. I’d sooner go for a weekend trip to a big town, rent an hour of a stranger’s time at a cafe and have them watch you struggle to fix your machine.

4 Likes

When my brother and then the computer shop had my Mac, the screen they had is the one that has an Options button from which they could get into the screen with the four available options, the last of which is Disk Utility. And they could not get the computer to install Mac OS from this screen. All attempts failed.

I don’t know the answer to this so are you guys suggesting that even though (the above), the system should be recoverable with the recommended procedure from the exclamation point screen? When this procedure is done and if to success, does the computer go to some place other than the screen with the Options button?

I just want to make sure.

Thanks.

DFU restore always works as long as there is no hardware fault, regardless of the state of the machine (anything from fully working to a wiped NOR which means a black screen, and this of course includes the exclamation point state). When the DFU restore is done, the machine boots into the macOS first-time assistant just like a brand new computer would. It is a complete factory reset.

1 Like