Any MSI laptop users that can share their experiences with using Fedora?

Hello community,

I’m hunting for my next laptop and so far I’ve returned 2 out of incompatibilities with Linux. A Dell XPS and an HP spectre x360. Both are state of the art machines and I’d love to keep either of those but the former drains battery while sleeping and the latter lags keyboard entries upon boot-up/wake-up for 20 secs. or so.

Before I go back to Lenovo (which is proving to be the good company for Linux here, believe it or not) I wanted to give a last try to another vendor and I’m interested in MSI laptops. Anyone here that can tell their experience with it using Fedora?

It’s not about manufacturers - it’s about components. I think before we can say anything, it is required to talk about a specific model and its components.

To pick up your example of Lenovo…the Thinkpad X and T series are fantastic machines (IMO the best), but if you look at their cheaper model (don’t know the names), you get plastic cases with crappy hardware. As usual, you get what you pay for.

Good clarification, If I wanted to target my question, I’d say Prestige or Summit from their MSI Business & Productivity laptops. But my question is more on the overall MSI Linux support. I went through their forum and I could see users are installing Linux on MSI but since most of the users would post about an issue, I don’t get a good sense of whether they’re happy with it or not.

Maybe MSI is not such a popular brand and not so many people has tried it.

Have you considered Asus? For me their gamer laptops, touted as ROG (republic of gamers), have been phenomenal running fedora.
Mine is about 1 years old and this is the inxi output.

[root@laptop jvian]# inxi -Fxx
System:    Host: laptop.home.domain Kernel: 5.14.6-300.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-9.fc35 
           Console: tty pts/0 DM: GDM Distro: Fedora release 35 (Thirty Five) 
Machine:   Type: Laptop System: ASUSTeK product: ROG Strix G731GU_GL731GU v: 1.0 serial: filtered 
           Mobo: ASUSTeK model: G731GU v: 1.0 serial: filtered UEFI: American Megatrends v: G731GU.310 
           date: 04/29/2020 
Battery:   ID-1: BAT0 charge: 54.0 Wh (97.1%) condition: 55.6/66.0 Wh (84.2%) volts: 15.7 min: 15.7 
           model: ASUSTeK ASUS Battery serial: N/A status: Not charging 
           Device-1: hidpp_battery_0 model: Logitech K350 serial: 200a-e6-28-b0-cb charge: 50% (should be ignored) status: N/A 
           Device-2: hidpp_battery_1 model: Logitech MX Ergo Multi-Device Trackball serial: 406f-06-e4-a3-3c 
           charge: 50% (should be ignored) status: N/A 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: L1: 384 KiB 
           L2: 12 MiB L3: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399 
           Speed: 4201 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4201 2: 4179 3: 4289 4: 4150 5: 4167 6: 4277 7: 4201 
           8: 4136 9: 4087 10: 4132 11: 4240 12: 4149 
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:3e9b 
           Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 470.74 bus-ID: 01:00.0 
           chip-ID: 10de:2191 
           Display: server: 1.20.11 compositor: gnome-shell driver: loaded: modesetting,nvidia 
           unloaded: fbdev,nouveau,vesa alternate: nv tty: 177x20 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:a348 
           Device-2: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:1aeb 
           Sound Server-1: ALSA v: k5.14.6-300.fc35.x86_64 running: yes 
           Sound Server-2: PulseAudio v: 15.0 running: no 
           Sound Server-3: PipeWire v: 0.3.37 running: yes 
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus-ID: 00:14.3 chip-ID: 8086:a370 
           IF: wlo1 state: up mac: 48:89:e7:c7:51:ff 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 3000 
           bus-ID: 03:00.0 chip-ID: 10ec:8168 
           IF: eno2 state: down mac: 04:d4:c4:75:77:6f 
           IF-ID-1: virbr0 state: up speed: 10 Mbps duplex: unknown mac: 52:54:00:cc:67:de 
           IF-ID-2: vnet0 state: unknown speed: 10 Mbps duplex: full mac: fe:54:00:71:ae:e7 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 
           chip-ID: 8087:0aaa 
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
Drives:    Local Storage: total: 476.94 GiB lvm-free: 45.31 GiB used: 65.48 GiB (13.7%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: BTNH90310SH8512A temp: 29.9 C 
Partition: ID-1: / size: 73.32 GiB used: 21.55 GiB (29.4%) fs: ext4 dev: /dev/dm-0 mapped: fedora_laptop-root 
           ID-2: /boot size: 771.4 MiB used: 258.9 MiB (33.6%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-3: /boot/efi size: 256 MiB used: 39.2 MiB (15.3%) fs: vfat dev: /dev/nvme0n1p1 
           ID-4: /home size: 73.32 GiB used: 43.65 GiB (59.5%) fs: ext4 dev: /dev/dm-1 mapped: fedora_laptop-home 
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 87.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 5300 
Info:      Processes: 323 Uptime: 1d 15h 47m Memory: 15.47 GiB used: 4.34 GiB (28.1%) Init: systemd v: 249 runlevel: 5 
           target: Compilers: gcc: 11.2.1 Packages: note: see --pkg flatpak: 5 Shell: Bash v: 5.1.8 
           running-in: tty pts/0 inxi: 3.3.06 
1 Like

That’s pretty good specs, thanks for sharing. I searched for “ROG Strix G731GU” and it looks impressive.

For documenting this thread, I won’t be considering MSI immediately as I’ve decided to keep a Dell XPS I recently acquired. It was a good deal. I will definitely consider ASUS if the other issue I have with the XPS (extended display is not working) is not fixed and I end up returning it. There is a chance I eventually go back to Lenovo since the Yoga I used for years was super reliable and everything worked fine there.