Android-tools not working? solved

Hi folks

I have installed the android tools with dnf.
adb is working but adb devices shows me an error message as follows:

no permissions (missing udev rules? user is in the plugdev group);

any ideas to fix it?

One of the following should work:

  • set your Android device to MTP mode
  • or run adb server as root (via systemd service): systemctl enable --now adb.service
  • or copy the udev rules; refer to /usr/share/doc/android-tools/51-android.rules (maybe not recommended?)

More context in rhbz#1509705

1 Like

thx Justin,

I have copied 51-android.rules from

git clone GitHub - M0Rf30/android-udev-rules: Android udev rules list aimed to be the most comprehensive on the net to /etc/udev/rules.d/.

then

sudo groupadd adbusers and sudo usermod -a -G adbusers $(whoami)

after a reboot I connected the phone and a dialogbox on my phone ask me to allow the connection via usb and now it works :slight_smile:

:- :+1:

the google 4a support ends in september and then I will try to get a LineageOS to run on it …

It is probably worth to try GrapheneOS since you have a google pixel. It is a hardened android version.

it look realy intresting but the support for the 4a is also running in end of life after august 2023