AMD Radeon Drivers on Fedora 37

Note: I created this post in response to comments on another thread about the Nvidia drivers. I asked a similar question in December:

It looks like there hasn’t been any progress on AMD drivers since then - the ROCm drivers specifically to get OpenCL running on the GPU for gaming/ML/Blender OpenCL/HIP type operations etc.

I have a new AMD 7950X machine. I’ve finally got an Nvidia RTX 3050 running properly on it.

Now I’m trying to get an MSI Radeon RX 6800 Trio Gaming Z running on Fedora 37. This was the originally intended configuration.

I haven’t managed to find any driver installation information relevant to Fedora, like the rpmfusion drivers/info for Nvidia GPUs.

The GPU works fine with the basic - Mesa - drivers that come with Fedora but e.g. blender can’t find an OpenCL/HIP-capable GPU to use.

There are drivers at AMD but nothing Fedora specific. I have tried installing the Ubuntu-specific drivers from on Kubuntu 22.04.1 on an AMD 5950X system with an MSI RX 6600 GPU but although the installation seemed to go well I don’t have an OpenCL-capable GPU there either as far as blender is concerned. Blender just uses CPU cores to render images.

Are there any guaranteed installation instructions for getting AMD Navi-based GPUs working, specifically with Fedora (but also with Kubuntu if you know of any).

As usual, there are various pages on the web and videos on YouTube detailing how to install AMD GPU drivers but the ones I’ve tried don’t work, and many seem to require particular versions of an OS or types of GPU.

I intended this machine (7950X) to be an all-AMD all-Linux machine but I may end up putting a 4070 Ti in it now that I’ve at least managed to get the 3050 running, and hope that the 4070 Ti isn’t too new for the rpmfusion drivers… (If it is I’ll end up back on Windows).

Thanks, as ever, for any info pointing in the right direction.

Hi, you can install amd rocm opencl with Fedora right now with:

sudo dnf install rocm-opencl

I’m working on hip support right now, but it’s in review, so it might take me a bit of time:

So follow that if you’re interested.

ROCm software is not installed on Fedora by default, but I try to remember to keep this page updated to help new users:

It’s worth noting that some HW might require you to update to Fedora 38, as Fedora 37 uses an older version of LLVM that is missing newer HW support.

1 Like