Amazon Workspaces won't launch

Been using Amazon Workspaces for about 3 weeks. I need it to do my work. A few days ago it no longer launches when I click the icon. Downloading it in software, but when I try to launch it now nothing happens. I think it updated and after the update it won’t launch.
Can’t find the package using dnf, so not sure what else to try.

So now to work i am forced to use Windows. Don’t want to use Windows anymore, so hoping to get this fixed.
Running Fedora 40 Workstation
Also, I have tried Unisntalling, and Reinstalling. Also completely deleted the directory.
Also have tried on 3 separate computers, all with Fedora 40, and it won’t launch on any of them.

You likely installed Amazon WorkSpaces on Flathub, which is not from the Fedora repository; hence, you cannot find it with dnf.

There was indeed an update five days ago. Check the details here: GitHub: Update on

The update is applied automatically by flathub bot, and workspacesclient_2024.1.4807 may cause the problem. You may want to create an issue against it. Meanwhile, you can easily roll back the update using Warehouse. Try downgrading the app to see if you can launch it normally. If that resolves the issue, consider disabling updates for this app.

Thanks. After downgrading it, the app launches again.

That fixed my issue.

How will I know if they release a new update to try and see if they fixed the issue.

I went to the website for the app, but they only say there is Ubuntu support for Linux, and they don’t have anywhere to report issues.

They won’t let me even access help without being an Admin or Root user for Amazon Workspaces, and I am not either.

you can report the issue to the Amazon Workspaces Flatpak maintainers. Create an issue here, and they can look into it.