Alienware 13 R3 - Headphone/Mic Jack

Hello everyone,

I recently installed Fedora 33 to my computer. It has been a better experience than Windows 10 until now. Thanks to everybody contributing to Fedora. But I have a small problem for which I could not find any information on the web.

My laptop has 2 audio jacks. One of them is combo jack which works with headsets with a mic and also works with headphones without mic. I have no problem on this one.

But the other jack was functioning a little differently on Windows 10. It could accept either of a mic or a headphone without a mic. I am able to use this jack only as a mic input on Fedora.

I tried to search the web but could not found any useful information. Maybe it is because I am not familiar with the terms and cannot find the right keywords to use.

I was hoping some of you here may point me into right direction to solve this. It is kind of a hobby for me to get all the hardware fully working on Linux. So, I am happy to go low-level stuff, if there is nothing ready to use.


Try installing Pavucontrol, which could help you to set up audio devices. When you plug a device into that slot, the device should appear in either the Output devices or Input devices tab and you should be able to switch your audio route to it.

1 Like

On a typical laptop the 2 audio jacks are mic and headphone. Yes the output jack typically also accepts the headphone with mic (4 barrel plug) or the headphone with no mic (3 barrel plug), but the other is typically for mic input only. This way they accommodate the headphones that have the dual plug cord as well as stand-alone mics.

If windows sees it differently and can use it as output, then I wonder what it is treated as. Possibly woofer for a 2.1 output?

I have used fedora with laptops for years, and have never encountered the usage you describe on the windows side (although I seldom use any audio output except usb on mine)

You did not tell us what hardware you have so it is difficult for anybody with similar hardware to test what you have described with audio output.

1 Like

@lruzicka thank you for the suggestion. For the aforementioned jack, when I plug in a headphone, it recognizes it in the Input tab, shows the Mic is plugged-in. Could not be able to change it to headphone.

@computersavvy It was able to function as a headphone. But I am not sure if it was stereo, it was mono out most probably.

arecord -l gives the following output:

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I also tried to use hda-analyzer from ALSA for more information but could not get it to working, it seems quite old. I was able to see some Vendor related nodes, but could not export it in a proper way. Will look for tools similar.