After update to kernel 6.6.6 the drive decrypt prompt doesn't work

The system (seemingly) won’t boot: It gets immediately stuck on a blank, black screen.

If I remove rhgb quiet from kernel parameters, I get the decrypt prompt in the command line and I can unlock the drive. SDDM loads correctly and I can login, but then I get another black screen: my KDE won’t start.

Not sure if these two issues are related, but the previous kernel 6.6.4 works without problems. Both the decrypt prompt and KDE.

(Funnily enough, the visual decrypt prompt screen is there, it just won’t show: I managed to resume the boot by blindly typing the password and it worked.)

Sounds like what I’m experiencing

Do you have an nvidia GPU?

If so how did you update to the new kernel? Using the cli with dnf or using gnome software app?

This seems a common occurrance when a reboot is done too soon after a kernel upgrade happens since it may interfere with building the kernel modules for the nvidia drivers.

The gnome software app does not wait for the module to be properly built before rebooting.

The fix seems to be to manually remove the improperly built module then rebuild it.

  1. sudo dnf remove kmod-nvidia-$(uname -r)
  2. sudo akmods --force
  3. reboot.

Of course if you are not using the nvidia drivers from rpmfusion then this does not apply.

Do not have an nvidia gpu. I have a thinkpad p14s gen 4 amd with a ryzen 7840u.

Also no nVidia GPU. I have a T14s with Ryzen 7840U, basically the same machine.

I wonder if the issue with modules could be similar though… however, I’m not seeing any AMD related modules to be removed and rebuilt.

$ sudo dnf remove kmod- <pressing TAB for autocompete>
kmod-30-6.fc39.x86_64       kmod-libs-30-6.fc39.x86_64

I have the same issue with a ThinkPad T14 Gen 4, same CPU as Joe.

However, I am using Fedora Silverblue, which I thought handled operating system updates atomically and wouldn’t end up in a partially upgraded state, so I think that probably isn’t it, at least for us AMD users.

I ran rpm-ostree rollback to downgrade to 39.20231205.0, and the prompt appeared as expected again. Then I tried the update to 39.20231215.1 again, but using rpm-ostree upgrade instead of Gnome Software Center. On reboot, the prompt does not appear again. When I edit the kernel parameters to add nomodeset then the graphical password prompt does appear.

It seems to be the issue mentioned in this reddit post and there they link to a patch for NixOS.

There’s a long email thread linked there about this issue upstream, it seems like they are aware of the issue but AFAIK as of Monday they haven’t fixed it yet. I wonder if Fedora could do something similar to NixOS in the meantime to get this working again?

AFAICS, we still have the config in Fedora which the NixOS patch readds (because they lost it at some point). So that patch won’t suffice.
Still your nomodeset experience hints at that area. It’s worth mentioning in the bug report on bugzilla.

Does removing plymouth work as a workaround for this?

Sure, I found this bug which sounds similar and mentioned this. Is this the one you had in mind or was there another bug for this issue?

I suspect that is is most likely related to amdgpu driver.
As of writing, there is no open issue at gitlab

Here the upstream diff stat what changed:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/?id=v6.6.6&id2=v6.6.4&dt=2

Any updates here? Is there anything to do except waiting for a fix? :thinking:

There were a bunch of updates that came out this week related to graphics. I ran all the updates and am now able to boot into and use my laptops screen on the 6.6.6 kernel. However, I still have to type blind of the full disk encryption unlock screen. After that, I get boot splash again, then it goes to gnome login, and it works normally from there on.

I am experiencing similar issues with a Lenovo ThinkPad Z13 Gen 1 with a Ryzen 6860Z. I managed to blindly input a password for the disk encryption, and then I got the slash screen and could log in successfully. Unfortunately, once the computer recovered from suspension, I had a blank screen and couldn’t recover it.

Just tested kernel-6.6.7-200.fc39.x86_64, it still has the same problem. For me once the screen goes black it stays black and doesn’t recover, no matter what.

I am seeing the same issue here as well.
Clean Fedora 39 install with Kernel 6.6.6 & kernel 6.6.7 on a Lenovo P14s (AMD CPU + Graphics)
While the password prompt does not appear, I can still type the password and the machine will boot and I am able to use it.

I created an issue at gitlab.freedesktop.org and someone reported that issue is fixed in 6.6.8 :crossed_fingers:
Black screen in kernel-6.6.6-200.fc39.x86_64 and later (#3072) · Issues · drm / amd · GitLab

Yes, I can confirm that the issue is fixed in kernel-6.6.8-200.fc39.x86_64 :smile:

This is awesome to hear!

In the meantime, I installed 6.6.7 via Fedora updates and it still doesn’t work. Not even KDE boots :confused:

Just got 6.6.8 through regular updates and I can confirm I can once again boot into KDE without any issues :tada: