After latest update: Grub no such device error

Hello everyone,

after yesterdays update my system refuses to boot, instead reporting

error: …/…/grub-core/commands:search.c:296: no such device: [Device ID]
error: …/…/grub-core/fs/fshelp.c:257:file ‘/ostree/fedora-721…/vmlinuz-5.4.14-200.fc31.x86_64’ not found.
error: …/…/grub-core/loader/i386/efi/linux.c:206: you need to load the kernel first.

on both ostree entries. The last commands I ran on my system were an rpm-ostree install + rollback and also an rpm-ostree upgrade (although I don’t remember if there was a reboot in between). I am grateful for any idea how I can rescue my system.

Hello @mzimmermann,

Have you looked at this Fedora Mag article about dracut? It may help with your boot problems, and provide info on how to get back up and running.

And from my own exeprience with trying to get to previous versions of Silverblue… this topic

Solved by @dustymabe with the following.

Replace the version of Fedora with the one you are running (31?) then use the ostree pull command.

1 Like