Action keys require FN key, ignore BIOS setting

Device: HP Spectre x360, Intel i5-1135G7, 8GB.

I haven’t seen a notification for updates in a while, so I just opened Gnome Software and performed all updates from there. After the reboot, I noticed something strange:

Whenever I want to lower backlight or change volume with my action keys, I have to press FN key. This was not the case before.

Maybe I was sleepwalking and changed this setting in the BIOS: I checked, flipped the setting, same behaviour. Flipped back, same behaviour.

Could it be something in Gnome that has changed? A setting that is not exposed yet in the GUI but is available through gsettings/dconf?

Can you please try this:

HP Notebook PCs - How to lock or unlock the fn (function) key