Ace Combat 7 fails to launch in Fedora 35


I have recently been trying to play ‘Ace Combat 7: Skies Unknown’ on Fedora via Steam’s Proton compatibility tool.

I tried a few different proton builds including experimental, but all of them got me nowhere: I press ‘play’ in Steam, Steam claims the game is launching, nothing happens and ‘play’ is back in a matter of seconds.

I have the latest NVIDIA drivers and other than the game not being natively compatible there are no other factors that I know of that could be getting in the way.

Thanks for any help.

Not to be nit-picky, but:
what version of fedora? fully updated?
what version of steam? installed from?
what version of proton? installed from?
Latest nvidia driver? version? installed from?

If you are fully updated and installed the 495 nvidia driver from the rpmfusion-nonfree-nvidia-driver repo or the rpmfusion-nonfree repo as well as both steam and proton from the rpmfusion-nonfree-steam repo then I cannot help. If you installed from somewhere else then I suggest you remove anything not installed from rpmfusion then reinstall from rpmfusion.

Software in the rpmfusion repos has been tweaked and tested for fedora.

Since I am not going to spend $60 for a game I won’t play I cannot test it for you.


Sorry for the late reply

Fedora 35 (latest, confirmed with a sudo dnf update)
Steam (also latest)
I tried a few different Proton versions, new and relatively old, including experimental.

The NVIDIA and NVIDIA CUDA drivers were installed via the terminal using commands found in the links below:

Everything is from RPM fusion to my knowledge.

I suppose Fedora was never intended as a gaming distro, so it’s not surprising that I’m running into problems like this, especially with the use of a compatibility layer.

I might dual-boot a more gaming-compatible/oriented GNU/Linux distro that has better compatibility.

Thanks for the help :slight_smile:

From a quick search, it seems like Steam + Proton on Nvidia isn’t very reliable, irrespective of the Linux distribution you use:

I see 2k issues on the proton GitHub tracker related to Nvidia…

Also some issues related to “ace combat”:

So maybe worth checking out the steam/proton forums to begin with, and they’ll be able to narrow it down to indicate if it’s Fedora specific.

I suppose that considering the current shortage, now is not the time to switch to AMD for better compatability… :thinking:

I scrolled through the one article involving AC7 (amazingly there was one on Assault Horizon too, that’s a surprise) but I couldn’t find anything that would help.

One of the users suggested a corrupted Proton install, but I’ve already tried re-installing Proton and using different versions of Proton, so that didn’t assist.

Thanks for the help anyway.

1 Like