Steam will not launch Proton games after f35 to f36 update

Steam Proton does not work after a f35 to f36 update. Native games run fine. I’m on a 2019 Razer Laptop with Nvidia GPU as primary. x11

OS: Fedora Linux 36 (KDE Plasma) x86_64
Host: Blade 15 Mid 2019-Base 3.04
Kernel: 6.0.8-200.fc36.x86_64
Uptime: 5 hours, 38 mins
Packages: 2708 (rpm), 15 (flatpak)
Shell: bash 5.2.2
Resolution: 2560x1080, 1920x1080
DE: Plasma 5.25.5
WM: KWin
Theme: Breeze Dark [Plasma], Adwaita [GTK2]
Icons: [Plasma], breeze-dark [GTK2/3]
Terminal: konsole
CPU: Intel i7-9750H (12) @ 4.500GHz
GPU: NVIDIA GeForce RTX 2060 Mobile
GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630]
Memory: 5898MiB / 15892MiB

Does the game start after you click Play (button turns to Stop), then almost immediately crash/close (button turns back to Play, game isn’t running)?

I’ve had that happen a few times, not related to an OS upgrade, but maybe a similar solution might work? For me, deleting that game’s corresponding compatdata folder (where its fake Windows installation is housed) - being sure to copy out any save games stored in there - and then trying to Play again worked, as Steam set the Windows environment back up fresh. Kind of like reinstalling Windows, just in a few minutes vs. hours!

Hopefully that helps

Deleting the compatdata does not work. Game never loads. None. I even have windows utilities I installed using proton for my midi controller that wont load.

This is the contents of the log file in the Rocket League folder.

info: Game: RocketLeague.exe
info: DXVK: v1.10.1-async
info: Built-in extension providers:
info: Win32 WSI
info: OpenVR
info: OpenXR
warn: OpenXR: Unable to get required Vulkan instance extensions size
info: Required Vulkan extension VK_KHR_surface not supported
err: DxvkInstance: Failed to create instance

Which proton version are you using?
Have you tried any other version?


Change proton version?
Change installer rpmfusion/flatpak?

I’ve tried multiple versions of proton, including GE. Treid forcing Wine D3D instead of Vulkan. Something is broken after updating from f35 to 36. Not my configuration. I’ve reinstalled graphics drivers, i’ve reinstalled steam multiple times on both RPM fusion and Flat Pak. nothing works.

You know… I expected my custom audio pipewire configurations to break and having to reinstall graphics drivers… But upgrading to 36 has cost me the ability to play proton games and now I’m unable to update to 37 because the dnf system-upgrade wont take the --allowraising or --skip-broken options.

Can you post the errors for the upgrade please.

Woops. I made a typo. Oh well… I’m backing up all my stuff at this point and prepping to nuke and pave if this doesn’t work.