4k display outputs blurry image while connected over hdmi


I’m using Asus Vivobook Pro 15-N580 with Dell s3422dwg display. I’m using Fedora 36 with Gnome and Wayland, kernel 5.19. I didn’t customize it in any significant way, it’s vanilla installation.

My graphics specs: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile], proprietary driver 515.76.

The thing is that if I try to connect the display to the laptop using a HDMI cable, the output resolution seems to be 1920x1080 instead of expected 3440x1440. If I connect the laptop using exactly the same HDMI, but adding HDMI-USB3 adapter (I’m using the one from a Macbook), the output resolution is correct and overall appearance is nice. I observed the same behavior under Fedora 35 and kernel, afaik, 5.15-5.17.

Could someone suggest how to enable 4k resolution while using plain HDMI? Thanks!

The specs on that system show HDMI 1.4 which supports up to 4k [ 3840 x 2160 24Hz |25Hz |30Hz.] Try setting that for the resolution on your external monitor. At 60Hz the max resolution you will get is 1920x1080.

Thanks for the tip! System settings does not allow me to go below 50 Hz for some reason. Is there other way of setting it?

If using xorg it is possible to use xrandr and create a custom definition. I don’t have any idea in wayland.

Are you by chance using wayland? If so have you tried with xorg to see if there is a difference in the settings.?

You say you using the nvidia driver but have you followed these steps to try and improve things.


I run nvidia as primary on my laptop with xorg (it only works with xorg) and have no issues with external monitors.

Thanks! I made my nvidia card to be primary device and xrandr worked like a charm.