I cannot get my LG monitor at 4K resolution

I recently brought a brand new LG 32UN650-w 4K monitor (which is awesome by the way). At first I couldn’t go ahead of fullHD resolution but digging a bit I discovered xrandr command and issuing

$ xrandr --newmode "3840x2160_30.00"  338.75  3840 4080 4488 5136  2160 2163 2168 2200 -hsync +vsync
$ xrandr --addmode DisplayPort-0 3840x2160_30.00
$ xrandr --verbose --output DisplayPort-0 --primary --mode 3840x2160_30.00 --rate 30

I could get my maximum achieving resolution (due to hardware performance). That configuration was retrieved by $ cvt 3840 2160 30 command.

Suddenly, after a reboot, this configuration not longer worked… I tried every combination without spinning a yarn. I’m currently running Fedora 34 with Gnome 40.4 up on Xorg server. Here my xorg.conf and here Xorg.1.log file.

My card is: [AMD/ATI] Juniper PRO [Radeon HD 5750] (it should achieve 4K@30 using DP port) and monitor is connected using its DisplayPort cable.

I tried getting supported monitor combination resolution using different tools

  • monitor-edid
  • edid-decode /sys/devices/pci0000:00/0000:00:03.0/0000:02:00.0/drm/card0/card0-DP-1/edid

No one of suggested ModeLine worked anymore. I also tried to boot different distro (Ubuntu 21, Fedora 35 beta) unsuccessfully. Windows 10 works like a charm at first shot. I switched from Wayland to Xorg (and back for test purpose), tried Xorg without configuration file (using default) and using a custom generated one, same result.

I’m running out of ideas at the moment. Thanks.

You posted on this forum so I assume you are presently running fedora.

What graphics card are you using. The card (and driver used) must be able to support the 4k resolution as well as the monitor and a good quality cable.

You said you tried both wayland and xorg so I have to presume that if you are using an nvidia GPU you must be running with the nouveau driver (the nvidia driver and wayland do not work together as yet). If using an nvidia GPU and nouveau it may be that nouveau itself cannot handle the 4k resolution. (I don’t know the current state of nouveau since I run nvidia GPU with nvidia drivers and xorg only.) The nvidia driver easily handles that resolution on a GPU that is capable of doing so.

If using a different GPU I have no suggestions.

Hey @computersavvy yes, sure, I’m on Fedora 34 (also tried 35 live).
As I mentioned in the post I have a ATI radeon HD5750 using radeon module, it is an old card but it supports 4k@30 through Displayport. Cable in use was included in monitor box, so I assume it is suitable.