Xrdp fails to load libvnc.so and refuses to start

I’m trying to get remote desktop working on my Fedora 38 Workstation computer but haven’t gotten very far. When I try to initiate a remote session, xrdg throws up a dialog with the connection log for the session which reads:


Connecting to sesman on
sesman connect ok
sending login info to session manager. Please wait …
login successful for user [xxx] on display 10
error loading libvnc.so specified in xrdp.ini, please
add a valid entry, like libxrdp-vnc.so or similar

libvnc.so is present on my system. I tried substituting libxrdp-vnc.so in xrdp.ini, but that also didn’t work.: the connection log was the same except that it reported that libxrdp-vnc.so also could not be loaded.

I’ve looked for a solution to this issue without success. Any suggestions? Thanks!


Try to downgrade mutter and test it again. See:

I found that remmina was the reliable RDP client.
I use it to connect to Windows VMs from fedora and ubuntu systems.

You might want to give it a try.

1 Like

The problem might be in package xrdp-0.9.22-3 from Epel.

I just upgraded Rocky Linux 9 and have same problem.
xrdp package upgraded from xrdp-1:0.9.21-1.el9.x86_64 to xrdp-1:0.9.22-3.el9.x86_64


The library /usr/lib64/xrdp/libvnc.so disapeared from the xrdp released 0.9.22-3.

Seems solved on the release 0.9.22-4


Thanks for the suggestion. I upgraded xrdp to the Rawhide Fedora 39 repo, 9.22, and that seemed to fix the problem after rebooting. Perhaps that remedied the same deficiency as downgrading mutter.


I would say on rawhide the patch is already included, yes. You can check if you have mutter version 4.2 or higher.

As others reported, xrdp is missing files at 1:0.9.22-3.fc37.

I was able to regress the package via ‘dnf downgrade xrdp’ to xrdp-1:0.9.20-1.fc37 and xrdp is functional.

On rocky linux 8, how do I downgrade xrdp, tried doing dnf downgrade xrdp but 1:0.9.22-3.el8 is already the lowest version installed.

You can downgrade to previous stable version, or upgrade to testing.


xrdp-0.9.21-1.el8 is the previous stable EPEL8 build.

Install x86_64 from koji:

dnf in https://kojipkgs.fedoraproject.org//packages/xrdp/0.9.21/1.el8/x86_64/xrdp-0.9.21-1.el8.x86_64.rpm

If you need another arch, copy the URL from koji.


xrdp- is the next build in testing now.

Install x86_64 from koji:

dnf in https://kojipkgs.fedoraproject.org//packages/xrdp/

Please give feedback on bodhi after testing the update. Testing helps to prevent problems like this from happening in the first place.

Thx, I was able to downgrade and get into my VM.

I solved the problem by: 1) Downgrading the xrdp package 2) saving off the libvnc.so file 3) upgrading to the latest 4) copying libvnc.so back into /usr/lib64/xrdp.