What should xrdp be doing?

Hello, first time user and first post. Fedora Workstation 35.

I’ve been playing around with xrdp today and I have it working, but I’m not sure if the behavior I’m seeing is correct.

If I am logged in locally and try to login to the same user account remotely, the session dies right after login.

If I am not logged in locally and try to login remotely (there’s only one account on the machine), the session comes up.

I’ve been told that xrdp should start another session under the same username, but I can’t find whether that’s true or not. I’ve seen quite a lot of information about trying to resume a session and that would be nice, but none of the options (mostly port=ask) is working. The forum posts I’ve found else also refer to a section in xrdp.ini that doesn’t exist, the [xrdp1] section.

Is this the correct behavior? If I’d like to resume an already existing login session, how might I do that?


1 Like

I’m not sure if this what are you looking for. After finishing setup with xrdp, then I go to Gnome Setting > Sharing. On there, enable screen sharing and remote login.

To remote current session (xorg) with the same session locally (same machine), I use remmina and select vnc connection. Enter the IP then on the notification it will pop up a message ask to allowing the connection. After that I get my current session through remmina.

Hmmm… well, not exactly I suppose.

I had setup xrdp and then, from a different workstation running Windows, tried to remote in using the same credentials as the user logged in at the console. I’d either get a black screen or the connection would die immediately. I found out that I had to be logged out of the local session on the workstation before xrdp could get in.

I would have preferred either:

  1. xrdp attaching to the currently open session, or
  2. Start up a new session with the same account.

I’ve tried a lot of different things, but nothing works. I’m xvnc I couldn’t get to work at all. I am now trying x2go.

All I’m really trying to do is get a remote GUI operating from the workstation I am usually in front of.

1 Like

I have used vnc for that. VNC is not foss, but it does work and you can use it for free in some situations. You would need to install the vnc server on the remote station and the vnc client on the workstation you are in front of. It does require a vnc account and an internet connection to function. I use it on my raspberry Pi for access from my desktop.

1 Like

Thanks for this. I apologize for not coming back. I just sort of gave up.

I tried this option in earnest this morning and could not get it to work. Basically I think the problem comes down to the plain options I have on macOS. realVNC complains that it can’t find a compatible encryption type. When I choose the option to set a password, I never get a prompt for a password in realVNC on the Mac side.

I suspect I screwed this up earlier because I thought I had to setup VNC at the command-line. I didn’t realize that GNOME already had this built in. In any case, it’s not working.

I planned to rebuild this machine anyway. It’s not a production laptop. I was just messing around.

I’m feeling pretty defeated, but that’s what happens when you play around with new OSs. I mean, I know someone who works for Red Hat. So, it just goes to show you how you can know everything and still not know everything.