XAMPP and VirtualBox on Asahi

Hello everyone,
I don’t know if I’m in the right place, but I’d like to share my problem with you. Yesterday I installed Asahi on my mac m2 and everything went fine. But today, when trying to install software ( such as Xampp or VirtualBox ) it doesn’t work. The error message I get for Xampp is: “errorcvp : Format error for exec()”.
Perhaps I’ve forgotten a specific procedure? Or are my components not suitable for these tasks?
Thank you for your help

From what I’ve seen on various topics, it’s generally due to a 64-bit to 32-bit download problem. But that’s not my case (after checking with the uname -m command, I’m in 64).
In addition, I tried to install the linux virtual machine software (Machine) directly, but when I run it, no connection is established and an error message appears:
"Unable to connect to libvirt qemu:///system.

Failed to connect socket to ‘/var/run/libvirt/virtqemud-sock’: No such file or folder

Libvirt URI is: qemu:///system

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/connection.py”, line 923, in _do_open
self._backend.open(cb, data)
File “/usr/share/virt-manager/virtinst/connection.py”, line 171, in open
conn = libvirt.openAuth(self._open_uri,
File “/usr/lib64/python3.11/site-packages/libvirt.py”, line 147, in openAuth
raise libvirtError(‘virConnectOpenAuth() failed’)
libvirt.libvirtError: Failed to connect socket to ‘/var/run/libvirt/virtqemud-sock’: No such file or folder "

As a novice, I’m quite lost …
Thanks for your help

i think the problem is the arch. your system is aarch64/arm64. virtualbox is made to run x86/x86_64 virtualization on same architecture. meaning that you cannot run it on a different type of system. at least not directly, and that is because you lack some prerequisite. notably the ability to execute code compiled for x86/x86_64. but there’s a solution for that, like for roseta on macos, linux have software that will let you run software made for another arch. there’s the box86, box64 and fex-emu. i think asahi team did choose to go with fex, and stated before (unless i’m mistaken) that they plan to integrate it directly in asahi in a future update. when that happen, it will give us the ability to also run wine, and windows games on our arm64 systems. there are already ways of testing it, but for final users it’s not ready yet, on both fex and asahi sides. and currently it require advanced mastery of system innerworkings …but we’re getting there.

to note: fex and roseta are not slow emulators, they are translation software that map instructions made for one cpu type to another type of cpu. those solutions are generaly very fast, close to native speed in best cases. point is: we’re waiting on inclusion in asahi for something similar to what roseta is for macos. and it will have ability to also run 32 and 64bit x86 code (x86/x86_64) where roseta can only do 64bits.

OK, thank you for your answer Freeaks. Does this mean that software like Xampp (and even others, because it’s not the only software I’ve tried to install) can’t be installed at the moment?
Or is this due to another problem?

others here will correct me if i’m wrong but, i think yes. there are a number of softwares that simply won’t work just yet on asahi because they are not made to run on arm at all. i cannot say for certain this is also the case for ‘xampp’ (is it some sort ‘lamp’ solution ? linux, apache, mysql, php, for web development, yes ?) maybe there some elements in the stack that aren’t working well on arm system ? one would need to try and report error output so we get to know what and where it fails. as far as i can tell, most software are in a transition phase to include arm in their supported archs list. in the case of virtualbox i think they have stated before that they will stay x86 only for the time being, but most others are not flat out refusing to support arm, they are just catching on. so the list of unsupported software is generaly shrinking.

OK, how can I contact them to report this? One last question: where do Asahi’s changes and upgrades appear (directly from their site?)?
Thanks for these details :wink:

And yes, Xampp it’s for development

Why do you think yo need Xampp ?

Fedora (all architectures) provides all needed packages for web development, Apache, Nginx, PHP, MySQL, MariaDB…

well, i’m deploring myself that asahi team is not properly reporting progress . you have to go through a large patchwork of social network accounts to get a grasp of what’s going on. on the main asahi account on mastodon, it is mostly PSA announcements, actual progress report appear there in a very slow and rare quantity. most of the news you can get from directly looking at asahi repo on github, or by looking at marcan account on mastodon, always mixed with personal and political opinions (that i personaly do not share). that is a bit unfortunate situation. but in the end they deliver good quality software and updates. it’s just the communication that is a bit sub-optimal.

anyway here’s the principal sources of news:
Asahi Linux · GitHub (asahi repo on git hub)
Hector Martin (@marcan@treehouse.systems) - Treehouse Mastodon (marcan on mastodon)
Sven Peter (@svenpeter@mastodon.online) - Mastodon ( asahi team member)
Asahi Lina (朝日リナ) // nullptr::live (@lina@vt.social) - VT Social (asahi “lina” responsible for gpu )
Janne Grunau (@janne@treehouse.systems) - Treehouse Mastodon ( asahi team member)
there are more, and you must currently peek at them all to get a glimpse of current situation intead of being able to just look at:
Asahi Linux (@AsahiLinux@treehouse.systems) - Treehouse Mastodon (official asahi news)
there is the official blog too but it’s even less updated than the official mastodon.

To do php and SQL. I wasn’t aware that Fedora allowed this. How can I access it?

LAMP (and all derivative, mamp, wamp, xamp and whatnot~amp) is just a name for a stack of software that you can install.

“L” is for linux, that you already have it.
“A” is for apache (or any other httpd you might prefer)
“M” is for mysql, but you could use other sql DBs
“P” is for php
you can manualy install all thoses. the usual way, through package manager. maybe there’s even a group list for that.

https://computingforgeeks.com/how-to-install-lamp-stack-on-fedora/ (i don’t know that site in any particular way but it seems it give you the steps you might need)

There is tons of article about installing web developement tools on Fedora and other RPM distributions

First found on search engine

about reporting to virtualbox, they already know. your report will most probably get ignored. but you can report it anyway just to add weight to the volume of request. maybe someday it will motivate them to do something about it…or not. in anycase it’s probably safe to assume nothing will happen in 2 years if not more, or if ever. lot of macos users also voiced their wish to run virtualbox in apple’s new arm arch. and the reply from virtualbox was something along the line of: “we’re providing support only for x86, won’t fix, cannot be done”.

Thank you very much, I’m off to give it a try.

Successful installation, but I don’t quite understand, when I have to code, I have to do it from the terminal, is that it?
While I’m at it, I’ve noticed that since I’ve been using Linux, my m2 sometimes reacts strangely (a pink screen for a few seconds, and even the computer crashes, I’ve had to turn it back on 2 times).

i think i heard about screen flashing pink before, but i thought that was fixed already ? here i don’t get those (macbook 14" m2pro). i also don’t get crashes. i’ve been testing this install for 3 weeks now, +10h a day, doing little C development, watching movies, browsing, listening music , the whole lot desktop usage, even some light gaming through retroarch mainly. here i find it quite stable. bluetooth hot swapping from headset to speaker on the fly, even putting the computer to sleep and wake it back up a few hours later, all worked fine for me so far.

about doing webdev coding, you can use whatever editor you want.
you just need to put the file in the directory you configured in apache settings to serve your files through httpd. you can code in terminal using vim if you want, or kdevelop or kate, or anything else you prefer. once you’re done, save the file, and point your browser to the correct location so you can test your work. in the link i pasted earlier, or in those @remi provided too, i think there must be some example setup provided to test out the stack is properly working. point is: you’ll need to gain basic level of mastery for httpd and sql DB servers setup.