X11 Screen Resolution Bug in KDE Settings

Using a fresh from scratch install of fedora-25, KDE spin. Attempting to configure Plasma X11 (due to some glitches in Wayland). I have two screens, both the exact same make/model of 4K Dell monitor. Each has a resolution of 3840 x 2160. That resolution is correctly shown in the KDE Settings / Display and Monitor / Display Configuration dialogue, in the ‘Resolution:’ dropdown. However, the resolution shown up where you drag screens around to ‘re-arrange’ them shows both screens as having a resolution of only 3072 x 1728. And this then causes the right-hand screen to overlap with the left screen as it is forcing the left screen’s left edge to start at virtual desktop pixel 3072 instead of 3840. I have tried everthing I can think of to muck around with the settings here to get it to recognize the correct screen resolution - all to no avail. I assume this is caused by a bug somewhere. Can anyone help me fix this?

Hi, there are some suggestions on the internet to delete ~/.local/share/kscreen.

But you could rename it with mv ~/.local/share/kscreen ~/.local/share/kscreen-backup instead of delete it, then logout your session and login again to reset it.

If something goes wrong and you can’t re-login, press alt+ctrl F3, login with your username, and rename back folder above with mv ~/.local/share/kscreen-backup ~/.local/share/kscreen, reboot.

Welcome to ask.:fedora:edora @

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Just to be clear, Fedora 25? Or is that a mis-type and you are actually using Fedora 35?

Opps, typo, yes. fedora-35.

Ok, this did work to reset the monitors’ configuration. It did also remove the widgets I had added to my desktop (to monitor CPU temp, etc). But I’m happy enough to recreate those.

fwiw, before I tried Syaifur’s solution I did try making changes in both the Wayland session and X11 session to see if perhaps having some different settings in each session was causing a clash-conflict. So like, e.g., the global zoom settings, which screen as primary, and such. When I did change some settings in X, then going back into Wayland those settings were affected, but I was able to set everything right in the Wayland session using the KDE Settings app. But I was never able to made the X11 settings work.

Also, I did try to ‘manually’ set the right-hand screen offset by using xrandr (i.e., xrandr --output HDMI-2 --auto --output HDMI-3 --auto --right-of HDMI-2). This did take effect, tho it put the displays into mirror mode, not expanded, side-by-side, desktop. It was at this point I gave up and performed Syaifur’s solution.

Tho it may no longer matter (but perhaps useful for some ultimate understanding of what went wrong perhaps?)

[jroc@jeffFedora ~]$ inxi -Fzx
System:    Kernel: 5.15.10-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-10.fc35 Desktop: KDE Plasma 5.23.3
           Distro: Fedora release 35 (Thirty Five)
Machine:   Type: Desktop Mobo: Gigabyte model: Z270X-Gaming 7 serial: <superuser required> UEFI-[Legacy]: American Megatrends
           v: F6 date: 04/24/2017
CPU:       Info: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake rev: 9 cache: L2: 1024 KiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67200
           Speed: 1040 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 1044 3: 835 4: 800 5: 800 6: 800 7: 801 8: 800
Graphics:  Device-1: Intel HD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0
           Device-2: Microsoft LifeCam Studio type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-6:5
           Display: x11 server: X.Org 1.20.14 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1: 3840x2160~30Hz
           2: 3840x2160~30Hz
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.3.2 direct render: Yes
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           Device-2: Logitech H600 [Wireless Headset] type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.2:4
           Device-3: Microsoft LifeCam Studio type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-6:5
           Sound Server-1: ALSA v: k5.15.10-200.fc35.x86_64 running: yes
           Sound Server-2: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Gigabyte driver: alx v: kernel port: e000
           bus-ID: 06:00.0
           IF: enp6s0 state: down mac: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 241.85 GiB (10.4%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB temp: 29.9 C
           ID-2: /dev/sda vendor: Seagate model: ST31500341AS size: 1.36 TiB
           ID-3: /dev/sdb vendor: Western Digital model: WD5000AAKX-001CA0 size: 465.76 GiB
Partition: ID-1: / size: 464.76 GiB used: 241.58 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p2
           ID-2: /boot size: 973.4 MiB used: 269.8 MiB (27.7%) fs: ext4 dev: /dev/nvme0n1p1
           ID-3: /home size: 464.76 GiB used: 241.58 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p2
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:   System Temperatures: cpu: 29.8 C mobo: 29.0 C
           Fan Speeds (RPM): cpu: 0 fan-1: 0 fan-3: 0
           Power: 12v: N/A 5v: N/A 3.3v: 1.68 vbat: 1.64
Info:      Processes: 459 Uptime: 20m Memory: 31.23 GiB used: 6.1 GiB (19.5%) Init: systemd runlevel: 5 Compilers: gcc: 11.2.1
           Packages: N/A note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.09