Workstation sleeps/hibernates on AC power after F37 -> F38 upgrade?

Upgraded my F37 work workstation to F38 with dnf system-upgrade and now cannot ssh/sftp to it from home. It seems to be going into a sleep/hibernate state while I commute home. It wakes up only when I go back to work and use the keyboard. This is not how things worked under F37, it is not the way I want it to work. I’ve got ‘never’ selected as the option for ‘put computer to sleep when inactive’ (just like it always was). It is on AC power.

dmesg provides these hints that I do not understand:
[ 7496.416971] systemd-sysv-generator[24798]: SysV service ‘/etc/rc.d/init.d/network’ lacks a native systemd unit file. Automatically generating a unit file for compatibility. Please update package to include a native systemd unit file, in order to make it more safe and robust.
[ 7593.998939] Lockdown: systemd-logind: hibernation is restricted; see man kernel_lockdown.7

1 Like

Ah! Thanks! Going to give this a go.
I could not find this when I was hunting around for it earlier because I’m using mate, and there is no ‘automatic suspend’ under the ‘power management’ in ‘settings’.

1 Like

The above may not be related to the sleep/hibernation issue, but suggests network hardware/drivers that predate systemd. If your issue with the system sleeping is not being able to use to connect to a sleeping system with some network app (e.g., ssh), you could check for wake-on-lan support. Fedora has a wol package, I use debian’s wakeonlan in Windows WSL2, and GeekFlare lists some w-o-l tools for other OS’s.