Wireless Intel AX211 broke after updates

Good morning,

I figured rather than bashing my head on this and reading through partial answers they may be related that I might be able to get the correct info about my problem and learn something along the way.

Long story short, got a new worklaptop Dell latitude 5540 and running a wireless ax211. I installed the beta of 39 a few weeks back thinking all good I’ll do the upgrade to the official addition later it’s only a week plus I’m off on leave. Once I performed a system update wifi broke.

I’ve tried uninstalling and reinstalling via dnf the iwl drivers and linux-firmware, and renaming the iwlwifi-so-a0-gf-a0.pvnm in /lib/firmware and rebooting but to no avail.

Bluetooth module is still working.

My apologies if I’ve missed something, I appreciate your help.

As it stands I have the following info:

1. uname -r

2. 6.5.9-300.fc39.x86_64

* dnf list installed iwl*firmware*

3. Installed Packages

4. iwlegacy-firmware.noarch 20231030-1.fc39 @updates

5. iwlwifi-dvm-firmware.noarch 20231030-1.fc39 @updates

6. iwlwifi-mvm-firmware.noarch 20231030-1.fc39 @updates


My dmesg

https://pastebin.pl/view/0f7c1af6

I have seen notes about the AX211 6e having problems but the AX211 6 works fine for me.
Mine show as this with lspci -nnk

05:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz [8086:2725] (rev 1a)
	Subsystem: Intel Corporation Wi-Fi 6 AX210 160MHz [8086:0024]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

Note the Wi-Fi 6 designation there.

I am also using F39 with the 6.5.9 kernel

# dnf list installed iwl*firmware
Installed Packages
iwlegacy-firmware.noarch                                        20231030-1.fc39                                     @updates-testing
iwlwifi-dvm-firmware.noarch                                     20231030-1.fc39                                     @updates-testing
iwlwifi-mvm-firmware.noarch                                     20231030-1.fc39                                     @updates-testing

From your dmesg I see this
[ 8.797862] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6E AX211 160MHz, REV=0x370 so yours appears to be the 6E version.

I would post the dmesg output and the related output of lspci -nnk as a bug against the iwlwifi driver for that card.

It may be worth the effort and cost (~$25) to switch to a Wi-Fi 6 version of that card.

Thankyou for your reply Jeff much appreciated.

Is there some way I can run an older code for the driver? I mean I think I made the media early October and it ran fine. I’ve just been going from 83 code all the way down the list but I’m assuming I’ll get to the point that it’s probably not supported.

I’ll get onto your recommendation to pass through as well. The workaround I think that will work is run 38 or see how the official 39 release goes :slight_smile: although I’m assuming as well that anytime I perform a a system update I will just end up back at the same situation.

If it worked before the update to 39 then it may work with some tweaking.
In any case it would be wise to report the bug because if it worked before, but not now, it indicates a regression and the fix may be easier to find.

The regression may be driver or firmware.

1 Like

One last question Jeff and forgive my ignorance. Where should I post the information Fedora forums, buzilla redhat, or intel?

Thankyou

bugs get reported on https://bugzilla.redhat.com/ and get distributed as appropriate from there.

As much information as possible should be included.

1 Like

Ok so by pure chance I finally have it running(but I assume it will possible break for an update).

I kept seeing this in dmesg " missing so-a0-gf-a0-83.ucode"

I downloaded linux-firmware-iwlwifi-fw-2023-10-12 from
https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git/

Extract and copied contents to /lib/firmware/ and overwrote all which included that missing file which Im almost certain was replaced with my previous dnf remove and installs but none the less.

Reboot and now successfully working.

I can finally move on. Thankyou Jeff for your help!

You need to raise the bug report for this to get fixed permanently.
Without the bug report the maintainer may not know there is a problem to be fixed and your discovery about firmware to use.

Please report exactly this into https://bugzilla.redhat.com/ against Fedora 39 linux-firmware package. You fixed your system, but all other systems with the same wifi are still broken. Also, your custom solution might break in the future because of some ABI incompatibility. It’s better even for you to have it fixed officially. Thanks!

@barratheworld try updating to kernel-6.6.4-200.fc39

That update does include the

% uname -r
6.6.4-200.fc39.x86_64
% ls -l /usr/lib/firmware/*so-a0-gf-a0-83* 
-rw-r--r--. 1 root root 545716 Nov 13 20:00 /usr/lib/firmware/iwlwifi-so-a0-gf-a0-83.ucode.xz
[gnw3@cerberusf39]~% dnf whatprovides  /usr/lib/firmware/iwlwifi-so-a0-gf-a0-83.ucode.xz
Last metadata expiration check: 2 days, 2:52:19 ago on Mon 11 Dec 2023 08:27:11 AM.
iwlwifi-mvm-firmware-20230919-1.fc39.noarch : MVM Firmware for Intel(R) Wireless WiFi adapters
Repo        : fedora
Matched from:
Filename    : /usr/lib/firmware/iwlwifi-so-a0-gf-a0-83.ucode.xz

iwlwifi-mvm-firmware-20231111-1.fc39.noarch : MVM Firmware for Intel(R) Wireless WiFi adapters
Repo        : @System
Matched from:
Filename    : /usr/lib/firmware/iwlwifi-so-a0-gf-a0-83.ucode.xz

iwlwifi-mvm-firmware-20231111-1.fc39.noarch : MVM Firmware for Intel(R) Wireless WiFi adapters
Repo        : updates
Matched from:
Filename    : /usr/lib/firmware/iwlwifi-so-a0-gf-a0-83.ucode.xz