Wifi will not often connect with Fedora 34

Hi there,

I’ve just done a clean install on my Lenovo W530 with Centrino Ultimate-N 6300 (rev 3e) wireless card. The wireless card finds it really hard to make a connection, with the message ‘failed to authenticate connection’ (or similar, i have connection now so dont want to lose it to check). swapping to a different network, or turning wireless on or off will eventually get it to connect.

EDIT: the warning is: ‘connection failed
activation of network connection failed’

I had read that rolling back the crypto policies might work so i tried:

update-crypto-policies --set DEFAULT:FEDORA32

to no effect and

update-crypto-policies --set LEGACY

with no effect either

Can anyone help out please? many thanks

ok, so update-crypto-policies --set LEGACY seems to have worked now, hadnt run properly before i suspect. CLOSED

OK, so there is an additional element to this issue now, it appears after more testing that sleep (closing lid or suspend from menu) wrecks the wifi card’s ability to activate a network connection as per my OP. restarting fedora fixes but this is kinda time-consuming

can anyone suggest a solution or a path towards one please? many thanks


Please provide the output of:

lspci -nv

Thanks Tom.

Hi friend.

I have a lenovo with centrino N 6200 and similar problem.
Solved adding these lines to /etc/NetworkManager/NetworkManger.conf


source: 1960021 – Automatic connection to wifi does not work.



Amazing thanks, worked a treat! to add to your excellent solution for anyone else looking, this is the complete sequence i used:

sudo gedit /etc/NetworkManager/NetworkManager.conf

then add these 2 lines:



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.