Wifi driver Problem for BCM43227 802.11b/g/n

I have broad-com driver of Broad-com Inc. and subsidiaries BCM43227 802.11b/g/n.
I had tried various solution for it but nothing happened. I also installed the rpm fusion free and non free version. and after rebooting the system I tried installing driver but that didn’t work at all. please help me. Note: I am just a beginner and never tried fedora my entire life. I have currently switched from windows.

So, you have rpmfusion-free and rpmfusion-nonfree enabled, correct? (To check, from a terminal, run dnf repolist) Those are just catalogues (“repositories”) of software, apps, drivers, and packages. Now you need to install the driver:

 sudo dnf install broadcom-wl

Also good to take a look at the output of following command:



That’s a Windows thing that is almost never required in GNU/Linux (unless you want to boot a newly installed kernel or other low-level stuff).

1 Like

Thanks dude I have now fixed my problem :innocent: :innocent: :innocent:


Glad it worked…

If you get a chance, please mark the “Solution” checkbox. (Or if you solved it another way, it’d be awesome if you can share that with us!)

I had the problem for long time but reinstalling the rpm fusion helped me with a simple command
sudo dnf update

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.