Wifi connection problem

After almost reboot my internet connection have some problem.
After system start, I see in right corner bottom applet wifi was perfect connected without any problem, error… but any sites doesn’t opened, and when I type ping google.com in konsole it doesn’t work. (ping: google.com: Неизвестное имя или служба)
Somtimes helps turn off and turn on wifi connection, but sometimes helps delete wifi connections, sometimes any. Just reboot several times.
My notebook have Fedora Linux 37 KDE and Windows 11. Windows wifi work perfectly.
I turn off FastBoot option from windows, it doesn`t help.
How i can find problem?

Network controller: MEDIATEK Corp. MT7921 802.11ax PCI Express Wireless Network Adapter
        Subsystem: AzureWave Device 4680
        Kernel driver in use: mt7921e
        Kernel modules: mt7921e

I may be way off but am experiencing similar symptoms that are being caused by DNS failures, which in turn are being caused by SELinux issues. Do you get any results including systemd-resolve from:

journalctl -b -g AVC

I found what is the problem…
Yeh, its DNS failure.
As I understand, it the problem is Windows does not unlock ip on reboot. Why they did this I don’t know, and how to fix it too. Only manually (well, I created a .bat file

ipconfig /release

, I run it before rebooting). But it’s a crutch! I tried to figure out how to add this command to the task scheduler so that it runs on reboot, but I don’t understand how to indicate that the event is a reboot. Judging by the information on the Internet, this is a very common problem, but no one has been able to solve it except with such a crutch so far … some kind of nonsense. In my opinion, everything is simple: register a command for the Reload button event and that’s it, but it’s not clear how to do it yet.

Today I catch this issue again. But I didn’t load Windows.
Just turned on notebook on Linux and worked perfectly. I saw updare notifications. Start updating. There was kernel update package. After reboot I lost access to internet. WTF?
I tried ‘ifconfig wl2p0 down’ and ‘…up’ but it’s didn’t work.

UPD: I continue to deal with this garbage further!
I changed the MAC in Linux (there is such an option in the network manager). I connect to the Wi-Fi point and the Internet immediately works. Reboting … fk, the same crap. Again I change the MAC address, everything is super, I reboot system - again it does not work.
I opened the router settings from my smartphone and see what is happening in the Device List.
Everything is beautiful here. there is a column with Lease Time, and so it is reset to zero from both Linux and Windows at each reboot. In general, i dont understand whats happens.
I turn off the connection to the wifi point, everything shows fine in the Device List. I turn on the point … it takes a long time to get IP … it connected, and in the Device List, everything shows about this and Lease Time is reset to zero. But there is no ACCESS to the Internet!
I change the MAC address again, reconnect. Internet WORKS.

I gess its problem in network adapter Mediatek.
I found the same problem on other forums/sites. Maybe driver isnt comletely working.
Ok, wait for patch… or find some decision.
Want to make genereting various MAC address on boot, before network service load.

UPD: made according to this instruction. Mac changes fine with every reboot



I will test. I’ll write the result.