Why are some categories not sending email


My discourse acct is sent to the default fire hose email configuration.

I am not receiving any emails to this site-feedback category. Any ideas why?


I think the default is not to be watching every category. That would be… a lot. (Like if we subscribed everyone automatically to every Fedora mailing list!)

Can you explain watching a category to me? What is that?

I turned on mailing list mode which overrides all email settings and I believe (and I’ve read elsewhere apparently discourse mailing list mode is a universally confusing and annoying topic) that it gives you everything.

Except for me, where I get emails for every topic I am not actually engaged in. Any topic / thread / category I’m participating in, I get nothing. I dont get copies of my own messages nor any of the replies.

Attaching my mail config in case it shows where I’ve gone wrong? That UI design is a bit of a case study isnt it?

Right now mail thru discourse is completely unusable because I am unable to follow any topics I’m actually interested in and get emails for topics I dont care about.

I changed the second dropdown in case it matters - unsure of how mailing list mode interactions with the email category (it says it overrides activity summary ?! i dont have any topics or categories muted)

I think mailing list mode is a big hammer that should override the top one and definitely always send you mail, but maybe the “only when away” setting is causing trouble. It may make sense to see to flip that default to “always” for this server.

1 Like

@duffy I seem to remember that when I was first setting up my Discourse account a couple of weeks ago, the “Site Feedback” category was muted by default. Go to the homepage (https://discussion.fedoraproject.org/) and scroll down - underneath all the categories there is a “Muted categories” section. Click + to open it and I think you’ll see “Site Feedback” there.

I also find Discourse mailing list mode confusing. I have tried this feature on and off since 2014 and it never worked the way I wanted it to from a traditional email client.

My best suggestion is to disable mailing list mode, and instead opt in to the categories you want to follow. Think of this step as the new “subscribe to mailing list” feature. There are two ways to change notifications for a category: either from your profile, or from the category landing page itself:

@duffy Does this help?

1 Like