What does this error mean?

I ran rpm-ostree upgrade and I got this message:

error: Could not depsolve transaction; 1 problem detected:
 Problem: package gnome-shell-extension-user-theme-43.0-1.fc37.noarch requires gnome-shell-extension-common = 43.0-1.fc37, but none of the providers can be installed
  - cannot install both gnome-shell-extension-common-43.0-1.fc37.noarch and gnome-shell-extension-common-43.1-1.fc37.noarch
  - package gnome-shell-theme-yaru-22.10.3-1.fc37.noarch requires gnome-shell-extension-user-theme, but none of the providers can be installed
  - conflicting requests

What do I do to fix this?

It appears that there’s a conflict.

The user-theme extension requires version 43.0-1 and the yaru theme required the newer 43.1-1 version of gnome-shell-extensions.

This is most likely temporary and should be resolved as soon as the updated user-theme-extension hits the repos. I suggest trying again in an hour or two.


You were right. Problem did not re-appear this morning when I ran the command again.

  crun 1.8.2-2.fc37 -> 1.8.3-2.fc37
  gjs 1.74.1-8.fc37 -> 1.74.2-1.fc37
  gnome-classic-session 43.0-1.fc37 -> 43.1-1.fc37
  gnome-control-center 43.4.1-1.fc37 -> 43.5-1.fc37
  gnome-control-center-filesystem 43.4.1-1.fc37 -> 43.5-1.fc37
  gnome-shell-extension-apps-menu 43.0-1.fc37 -> 43.1-1.fc37
  gnome-shell-extension-common 43.0-1.fc37 -> 43.1-1.fc37
  gnome-shell-extension-launch-new-instance 43.0-1.fc37 -> 43.1-1.fc37
  gnome-shell-extension-places-menu 43.0-1.fc37 -> 43.1-1.fc37
  gnome-shell-extension-user-theme 43.0-1.fc37 -> 43.1-1.fc37
  gnome-shell-extension-window-list 43.0-1.fc37 -> 43.1-1.fc37
  libdnf 0.68.0-1.fc37 -> 0.70.0-1.fc37
  xorg-x11-server-Xwayland 22.1.8-1.fc37 -> 22.1.9-1.fc37
Run "systemctl reboot" to start a reboot
1 Like