Weston doesn't receive commands from XWayland

Hi! I’m working on an embedded project and i want
to use weston, i added xwayland = true in the
[core] and path = "/usr/bin/Xwayland"
in [xwayland] but in htop there is no
Xwayland process running. Also, i can’t
run any apps using X like xeyes

I’m using fedora server 40 custom.

What could be wrong?

1 Like

Do you have xorg-x11-server-Xwayland package installed?

Yeah, I do have it installed.

1 Like

Launch weston from tty and see if it prints any error messages.

The only messages are related to me not having seatd, and it using logind instead.

1 Like

Seems to a bug. Passing args directly to weston works.

1 Like

Added f40, noarch, server, weston, xwayland

You’re setting this in ~/.config/weston.ini? When weston is invoked in a terminal, does it indicate that it’s reading from that file?

I noticed you’re using spaces around the =. Despite there being code in Weston’s custom config parser that looks like it’s intended to handle spaces, it doesn’t seem to work with them present. Try:

[core]
xwayland=true

All of the examples are written that way. man weston.ini says “The spaces are significant.”, but I’m not sure what that means.

Also, you don’t need to specify the path to Xwayland.

1 Like

Oh, that explains a lot. I think i added the spaces around.

1 Like