VNC Server Issue with Fedora 36

HI Guys
I have followed this guide to get a server running.
But i am getting errors when i try to run it.
See terminal error here

Make sure you’re running Xorg. VNC currently only works over Xorg. If you’re running Wayland, you won’t have an :0 or :1 display to connect to.

1 Like

I have just rebooted and started Xorg Gnome and get same errror

systemctl status vncserver@:1.service
× vncserver@:1.service - Remote desktop service (VNC)
     Loaded: loaded (/etc/systemd/system/vncserver@.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Fri 2022-08-26 21:55:11 BST; 45s ago
    Process: 1235 ExecStartPre=/usr/libexec/vncsession-restore :1 (code=exited, status=1/FAILURE)
        CPU: 8ms

Aug 26 21:55:11 osopolar systemd[1]: Starting vncserver@:1.service - Remote desktop service (VNC)...
Aug 26 21:55:11 osopolar vncsession-restore[1235]: No user configured for display :1
Aug 26 21:55:11 osopolar systemd[1]: vncserver@:1.service: Control process exited, code=exited, status=1/FAILURE
Aug 26 21:55:11 osopolar systemd[1]: vncserver@:1.service: Failed with result 'exit-code'.
Aug 26 21:55:11 osopolar systemd[1]: Failed to start vncserver@:1.service - Remote desktop service (VNC).

Normally, Xorg starts with display :0. Are you able to try display :0 instead of :1 ?

you mean change in the config file?

Yes? You’ll have to forgive me as it’s been over a decade since I administered a VNC environment.

I dont see that option in the config file

Are you able to help me further re the location of this setting ?