VMware don't launch after latest kernel update


My vmware workstation player of 15.5.6 version isn’t launching after the latest kernel update.
I get the following error when i try to run vmplayer from terminal:

/usr/bin/vmplayer: line 105: 8026 Segmentation fault (core dumped) “$BINDIR”/vmware-modconfig --appname=“VMware Player” --icon=“vmware-player”

I was using the following fix from mkubecek after every single kernel update until now:

I tried to completely uninstall and then reinstall it, nothing worked.

Thank you very much for all kind of help in advance.

1 Like

You need to build the kernel modules again manually every time after you update the kernel. A workaround for it would be to boot up with the last used kernel where it used to work as you had already built the kernel modules for it.


Or, you can use libvirt+KVM/QEMU with GNOME Boxes or virt-manager.


I just managed to switch back to kernel 5.7 and it’s working fine, thank you.
Someone said that even virtualbox stopped working on 5.8.

1 Like

Thank you for the recommendations. Can i actually use my vmware images with these?
It would be critical to use the best VM with the best possible performance.

1 Like

It looks possible:
How to run the Virtual Machine Image on KVM/QEMU


There is converters for all sorts of virtual hard disk. You may have to merge the split vmware hdds into a single one before converting to a qcow2 (see here: https://stafwag.github.io/blog/blog/2018/07/01/migrate-a-windows-vmware-vrtual-machine-to-kvm/). And just make a copy of your existing virtual hdd (so you can always revert to the status quo.


@t0xic0der Normally, the VMWare Workstation GUI will prompt to build the the kernel modules for a new kernel. However, starting with Kernel version 5.8, even the GUI won’t start. The problem persists with the latest kernel build 5.8.6.

@vgaetera Unfortunately, using KVM isn’t an option for me (and I assume for others), because I need VMs that I can configure to look like real machines (e.g. changing BIOS strings, etc) for malware analysis.


Welcome to Fedora! @seanthegeek

Indeed it is true that the VMWare GUI comes up with a prompt is the kernel modules are not available/built for the currently installed kernel. The absence of the prompt is kinda an issue at their end. The obvious workaround would be to falling back to the kernel where it worked the last time and wait for VMWare to address the issue.

(Also, for them to address the issue - they must know about this in the first place. Feel free to hit their bugtracker stating the issue if you think VMWare can help solve the issue :sweat_smile:)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.