VM issue at boot on Fedora 35 host

I have recently upgraded my laptop from fedora 33 to fedora 35. I have one VM using libvirt and qemu/kvm on the laptop that is running a vanilla fedora 34 workstation install. While running the fedora 33 host I have never encountered an error with the VM.

After the upgrade to 35 on the host I have been unable to properly boot the VM.

The first time I tried booting it the console window for the VM just hung for some time then disappeared and the vmm manager showed as disconnected. Reconnecting the manager to the VM showed it as running, but doing anything except a shutdown repeated the hang/disconnect/crash/whatever.

With quite a bit of trial & error I finally was able to determine that the VM is not crashing, but rather that it is totally unable to launch graphics mode.

Using grub to edit the command line and launch the boot in run level 3 works perfectly. Once I have logged in at run level 3, attempting to launch graphics with “startx” also gives the disappearing console window and the disconnect from the vmm manager.

I filed a bug on qemu 2007363 – Unable to launch Fedora 34 VM in graphical mode that so far has given no results although I have sent a lot of detail as to what is happening. I suspect it is likely an issue with the spice-server or spice-viewer but it has not yet been determined or fixed.

Has anyone else seen similar issues or problems? Hopefully this will be able to be fixed very soon.

Try switching SELinux to permissive mode to isolate the issue.

As a workaround, navigate to the VM hardware config:

  • Video settings:
    • Disable 3D acceleration if possible.
    • Change the video adapter model to QXL/VGA.
  • Display settings:
    • Change the display server type to VNC.
    • Use any VNC viewer like GNOME Connections.

I have tried the changes recommended.

The original was QXL with spice server.
SELinux is and has been permissive.

With either QXL or VGA and spice server it will only boot to run level 3
With Virtio and spice server (3d accel disabled) it does boot to graphics, though poor resolution.
When I try to enable 3d accel with the virtio it gives a qemu error

Same if I select VNC server instead of spice.

With spice server and QXL or VGA video at least it will boot to run level 3.

So far, even with the beta release of F35 and fully updated on the host, the VM is unable to boot into graphical mode regardless of the combination of display mode and video mode selected. As noted, some combinations will boot to run level 3, some won’t. Nothing enables booting to run level 5 or obtaining graphics after a log in on run level 3.

1 Like