Vlc no audio playing mp4 video (mpeg aac audio mp4a)

Hi all,
I’m trying to figure it out what the problem is… but I can’t find the solution.

I’m running Fedora 32, trying to get audio (video is ok) from an MP4 file on VLC.
I’ve installed vlc- from rpmfusion and also a lot of other “gstreamer1” packages:


Still no luck.
Thanks a lot in advance for your help!

1 Like

Try installing ffmpeg from RPM Fusion to enable MPEG-4 support.

If you need H264 and H265 support you can install x264 and x265 from there as well.

1 Like

Did you have both the rpmfusion repositories enabled? Installing vlc should pull in all the required dependencies on its own:

Thanks @kiko964 I already got them… but still no audio

$ rpm -qa |egrep “ffmpeg|x264|x265”

Thanks @FranciscoD, I think I got all all the rpmfusion repos enabled…

$ sudo dnf repolist
repo id repo name
fedora Fedora 32 - x86_64
fedora-cisco-openh264 Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 32 - x86_64
rpmfusion-free RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates RPM Fusion for Fedora 32 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 32 - Nonfree
rpmfusion-nonfree-updates RPM Fusion for Fedora 32 - Nonfree - Updates
updates Fedora 32 - x86_64 - Updates
updates-modular Fedora Modular 32 - x86_64 - Updates

$ sudo dnf update vlc
Last metadata expiration check: 2:23:37 ago on Sat 02 May 2020 05:45:59 PM CEST.
Dependencies resolved.
Nothing to do.

But I got no audio on VLC… I have tested the same mp4 video file, with “mpv” player, and the audio is ok! I don’t know what can be failing for my VLC instance…

1 Like

Report it in rpmfusion bugzilla
I don’t use rpmfusion but I am using the vlc from UnitedRPMs and plays mp4 with audio without problems…

1 Like

Thanks @davidva
I installed VLC from UnitedRPMs too (together with a lot of dependencies and other packages), but the problem persisted.

Fortunately I found a temporal solution or workaround. Let me share it over here, just in case someone else have this problem and is reading this post.

Follow instructions from: VLC 3.0.8 : no sound mp4a in video - The VideoLAN Forums

Tools - Preferences - Show ALL settings - Input codecs - Video Codecs ==> Preferred decoders list: avcodec (this list was previously empty)

Now I have sound on VLC too.

I’m not able to really explain why this worked (why “avcodec” is working and the default codec was not), but it solved my problem!

Thanks all! I’m really loving Fedora 32! :clap: :clap:

1 Like

Very strange; because generally " avcodec is enabled by default; I also have empty “Preferred decoders list” but I have audio. Maybe regression with faad2? or a problem with faad2 decoding, is necessary open a ticket in Vlc…


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.