VirtualBox still can't run in Fedora 36 until now?

Hai All,
I tried again to install virtual box from official website( )
In fedora 35 virtual box installed from official site is working well. Since I upgraded to fedora 36 virtualbox won’t works. but in the last tried the error message is different, now virtualbox can install in fedora 36 but won’t run because failed building kernel module?
How to solve this problem? because I want use vagrant with virtualbox.
I don’t enable secure boot in BIOS.

uname -r

systemctl status vboxdrv
× vboxdrv.service - VirtualBox Linux kernel module
     Loaded: loaded (/usr/lib/virtualbox/; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2022-06-21 15:35:18 WIB; 2min 29s ago
    Process: 792 ExecStart=/usr/lib/virtualbox/ start (code=exited, status=1/FAILURE)
        CPU: 5min 6.785s

Jun 21 15:32:53 fedora-linux systemd[1]: Starting vboxdrv.service - VirtualBox Linux kernel module...
Jun 21 15:32:57 fedora-linux[792]: Starting VirtualBox services.
Jun 21 15:32:58 fedora-linux[792]: Building VirtualBox kernel modules.
Jun 21 15:32:58 fedora-linux[1056]: Building VirtualBox kernel modules.
Jun 21 15:35:18 fedora-linux[792]: failed: Look at /var/log/vbox-setup.log to find out what went wrong.
Jun 21 15:35:18 fedora-linux systemd[1]: vboxdrv.service: Control process exited, code=exited, status=1/FAILURE
Jun 21 15:35:18 fedora-linux systemd[1]: vboxdrv.service: Failed with result 'exit-code'.
Jun 21 15:35:18 fedora-linux systemd[1]: Failed to start vboxdrv.service - VirtualBox Linux kernel module.
Jun 21 15:35:18 fedora-linux systemd[1]: vboxdrv.service: Consumed 5min 6.785s CPU time.
[afiadi@fedora-linux ~]$ vboxmanage --version
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (5.18.5-200.fc36.x86_64) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
[afiadi@fedora-linux ~]$ sudo /sbin/vboxconfig 
[sudo] password for afiadi: Stopping VirtualBox services. Starting VirtualBox services. Building VirtualBox kernel modules. failed: Look at /var/log/vbox-setup.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
as root.  If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system's documentation for more information.

Thank You in Advance

1 Like

It seems virtualbox will not run with the 5.18 kernels on Fedora.I’m having the same issue.The work around seems to either download and install the test version from virtualbox or wait for a newer version to be released.


Indeed. To be clear, this isn’t a problem with Fedora itself, but Oracle needing to add support for newer kernel. Fedora doesn’t provide VirtualBox, itself, though RPMFusion packages the open source bits, and while it may not have all the same features as the PUEL version, it will likely have better testing/integration with Fedora in general and it’s less creepy.


For me , VirtualBox works fine. I have Version 6.1.34_rpmfusion r150636

  Kernel: 5.18.5-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36
    parameters: BOOT_IMAGE=(hd1,gpt4)/boot/vmlinuz-5.18.5-200.fc36.x86_64
    root=UUID=a5e3ea96-8fcd-4800-9f85-1326fe163503 ro
    resume=UUID=5fa37652-10a5-40d9-9edf-0cba69b9e3c6 rhgb quiet
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING Z490-PLUS v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2601
    date: 10/29/2021
  Info: model: Intel Core i7-10700F bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF0
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 800/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 799 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800
    14: 800 15: 800 16: 800 bogomips: 92796
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: ASUSTeK
    driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:7340
    class-ID: 0300
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.2
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu display-ID: 0
  Monitor-1: DP-3 res: 1920x1080 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 5500 XT (navi14 LLVM 14.0.0 DRM 3.46
    v: 4.6 Mesa 22.1.2 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Device-2: AMD Navi 10 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1
    chip-ID: 1002:ab38 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes


Yeah, I know it. but I want virtual box like in Fedora 35 installed from official website not from rpmfusion.

1 Like

In that case, you’ll want to inquire with Oracle able it. Fedora does not package it.

1 Like

Oke solved. Finally I can install and run virtual box official with install virtualbox the lastest build. I’ve gotten from this thread:

Thank you All.


is VirtualBox working fine on your new Fedora36. My VMs are all breaking after some Minutes.

Yeah is working fine, I use the lastest kernel version in Fedora 36 workstation

Started to have some problems since latest update. Quite frequently the VM just freeze, for ever. Running VirtualBox 6.1.34_rpmfusion r150636

  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36
    parameters: BOOT_IMAGE=(hd1,gpt4)/boot/vmlinuz-5.18.7-200.fc36.x86_64
    root=UUID=a5e3ea96-8fcd-4800-9f85-1326fe163503 ro
    resume=UUID=5fa37652-10a5-40d9-9edf-0cba69b9e3c6 rhgb quiet
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Fedora release 36 (Thirty Six)

I see. You have version VirtualBox-6.1.34, but I install the lastest TESTING build with this version.

The link download and installation is in my solution above.

Remember also, that if you install from the oracle site and it works then there is a manual step required with every subsequent kernel update.

You will have to manually rebuild all the modules since they have to be built explicitly to match each kernel version.

When you install from the rpmfusion site there is an akmod package that automatically rebuilds the module for you with a kernel update.

1 Like

I’m sorry bro, you wrong, you don’t need to do anything if your fedora system upgrade kernel. It’s just works like virtual box official in Fedira Linux 35. Look at my SS below:

In my SS before this SS above, I use kernel version 5.18.6-200, but in my SS above I already update my Fedora system to the lastest kernel, and Virtual box still running smoothly and properly.
I already said in this thread I don’t use secure boot enabled.

The problem is basically because secure boot requires VirtualBox kernel modules signed to run, you need to sign and compile. I found the solution here.

Also, y translate and put additional details in Spanish here:


1 Like

Any updates on this? Fedora 38 is coming soon and VirtualBox doesnt even have a F37 package…

There is an open ticket at the oracle bug tracker but nobody seems to care enough to start rebuilding for f37.

The solutions offered are:

  • install the f36 package in f37, works without issues (just need to manually point the repo file to the f36 repo)

  • install virtualbox from rpmfusion

Edit: the f36 package from Oracle (virtualbox repo) will also work in f38, see #21451 (Upcoming problem for Fedora 38 rpms) – Oracle VM VirtualBox


This might be truth till the next kernel headers are needed. Then you will have hick ups again.
Anyway i had same fights with Virtualbox, till i was courageous enough to test the virtual machine manager. It is much better integrated in Fedora. Since then i have peace with virtualization.

Is it because you use vagrant, that you insist using VBox download direct from them?

Probably more peace with VirtualBox you also will have using the LTS kernel from copr.

I have had no issues running VirtualBox when I install it from rpmfusion, and it updates the kernel module automatically when needed.

1 Like