Can't start virtualbox service(vboxdrv.service) in fedora 36?

Every time try to start virtual-box service (vboxdrv.service) -

sudo systemctl start vboxdrv.service

i ran into a error -

Job for vboxdrv.service failed because the control process exited with error code.
See "systemctl status vboxdrv.service" and "journalctl -xeu vboxdrv.service" for details.

According to error statement i have tried the output result of -

systemctl status vboxdrv.service

but i am still getting nowhere. How i can resolve this issue?

Is your user in vboxusers group?

And what do you get with this command?

journalctl -xeu vboxdrv.service

VirtualBox from rpmfusion or from Oracle repo (kmod vs. dkms)?

Did you install the required dependencies (kernel-headers, -devel, -modules, make, gcc, …)?

It has some case of the cause; first, there are insufficient conditions to start driver such as some libraries and hardware requirements… Second, Virtualbox configuration had been broken. In the second case, you need to reinstall Virtualbox.

Could you give me more information?

If you installed virtualbox from the oracle repo then it is up to the user to identify and install any missing dependencies. If you installed it from the rpmfusion repo then all needed dependencies to build the modules should have been handled for you.

The answer to the question from @augenauf in post # 2 would tell us where the problem lies.

Sorry to all not replying any time sooner, I just disabled my secure boot, and now Virtualbox is working fine.