Vdpauinfo error, missing kernel modules and nvidia driver issues

Hey guys,

I seem to having a lot more trouble with this version of Fedora than previous. I had searched here and found the porper posts on how to install drivers suitable for my 1060, sadly when I input:
$ vdpauinfo
display: :0 screen: 0
Error creating VDPAU device: 1

But when going back to retrace my steps it says that:
Package vdpauinfo-1.4-3.fc36.x86_64 is already installed.
Package libva-vdpau-driver-0.7.4-111.fc36.x86_64 is already installed.
Package libva-utils-2.14.0-1.fc36.x86_64 is already installed.

I have cleaned all packages and I’m a bit uncertain as to how to approach this… Upon rebooting, it is now saying that I am missing kernel Modules and it is reverting back to Nouveau.

Don’t ever recall this being an issue with 35, but I can’t go to an old version because I had given another Distro a try so no snaps would’ve been saved.

I was just unbanned from World of Warcraft and I NEED TO PLAY THIS GAME

Thanks :wink:

I would guess that you have an nvidia GPU since you mention 1060.
Whenever you post something like

then it is also helpful if you give us more detailed hardware info as to why that comment was made.
Please post the output of inxi -Fzxx in the </> Preformatted text tags so we can see the hardware referenced.

Have you installed the nvidia drivers from rpmfusion? If so, and if the drivers are loaded, then you should see a 4 or 5 line response when you do lsmod | grep nvidia

If you have secure boot enabled then you will either need to disable secure boot in bios or take the steps to sign the nvidia modules before they will load.

BTW, your comment

indicates a possible addiction and we really, really, do not care about that and the information is irrelevant to the technical problem. We will help to solve the technical issues but you have to deal with the addiction part yourself.

Kernel: 5.18.18-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.4 tk: GTK v: 3.24.34 wm: gnome-shell
    dm: GDM Distro: Fedora release 36 (Thirty Six)
  Type: Desktop Mobo: ASRock model: X470 Gaming K4
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: P1.00
    date: 03/27/2018
  Info: 8-core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 768 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 3293 high: 3342 min/max: 1550/3200 boost: enabled
    cores: 1: 3284 2: 3257 3: 3301 4: 3303 5: 3342 6: 3342 7: 3302 8: 3297
    9: 3270 10: 3201 11: 3315 12: 3318 13: 3293 14: 3264 15: 3314 16: 3298
    bogomips: 102194
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com.
    driver: nouveau v: kernel arch: Pascal pcie: speed: 2.5 GT/s lanes: 16
    ports: active: DP-1,HDMI-A-1 empty: DP-2,DP-3,DVI-D-1 bus-ID: 26:00.0
    chip-ID: 10de:1c03
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: nouveau display-ID: 0
  Monitor-1: DP-1 model: MSI G241V E2 res: 1920x1080 dpi: 93
    diag: 604mm (23.8")
  Monitor-2: HDMI-A-1 model: MSI G241V E2 res: 1920x1080 dpi: 93
    diag: 604mm (23.8")
  OpenGL: renderer: NV136 v: 4.3 Mesa 22.1.7 direct render: Yes
  Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel bus-ID: 3-4.4.1:5 pcie: chip-ID: 08bb:29c0
    speed: 2.5 GT/s lanes: 16 bus-ID: 26:00.1 chip-ID: 10de:10f1
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 28:00.3 chip-ID: 1022:1457
  Device-3: Texas Instruments PCM2900C Audio CODEC type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.18-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 1f:00.0
    chip-ID: 8086:1539
  IF: enp31s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.07 TiB used: 634.97 GiB (30.0%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdc type: USB vendor: Kingston model: DataTraveler 3.0
    size: 28.9 GiB serial: <filter>
  ID-1: / size: 222.57 GiB used: 88.14 GiB (39.6%) fs: btrfs dev: /dev/sda2
  ID-2: /boot size: 973.4 MiB used: 272.6 MiB (28.0%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 222.57 GiB used: 88.14 GiB (39.6%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: nouveau temp: 53.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 282
  Processes: 366 Uptime: 1d 17h 35m Memory: 15.55 GiB used: 7.32 GiB (47.1%)
  Init: systemd v: 250 target: graphical (5) default: graphical Compilers:
  gcc: 12.1.1 Packages: N/A note: see --pkg Shell: fish v: 3.5.0
  running-in: gnome-terminal inxi: 3.3.19

The lsmod does not return anything when I copied your command

That tells me that you need to read and act upon this

1 Like

Looks to me that it already is, just checked. What are the steps to Sign the Modules?

You can find those instructions here:


If your bios contains TPM it may not be possible to disable secure boot without also disabling TPM. Some are that way.

Unless you need secure boot or tpm as jeff posted you can disable them.You also might try to log in with xorg instead of wayland.

I’m not sure what’s going on, says that secure boot is disabled, I don’t see any mention of TSM in Bios and nothing changes when I switch to Xorg… I wonder what changed from 35 to 36 that I’m having a hard time getting things to work?

Also I get permission denied when I run that command in the How-to secure boot and when I do :

$ mokutil --import /etc/pki/akmods/certs/public_key.der 0 < 15:02:28
EFI variables are not supported on this system

pops up

That tells me you possibly installed the system in legacy mode and are not using efi, which would mean the key is useless. AFAIK those keys only work with secure boot when using uefi booting.

The actual command is sudo mokutil --import etc/pki/akmods/certs/public_key.der. It must be run using sudo or when logged in as root to have the permissions needed. You also must use sudo to use the kmodgenca command if you did not do so already.

To verify the boot style please run ls /sys/firmware/efi . If that returns a result then you booted using efi. If not or it gives an error then you are in legacy mode boot.

1 Like