Utopia P2P Ecosystem installation on Fedora 35

Hello everybody, I tried installing the Utopia using the rpm. file which is provided on the website. I wanted to try it out and see for myself what all the fuss is about. Anyway, when I tried o install the package this message appeared : Unable to
install utopia: Error running transaction: package utopia-1.1-238x86_64 does not verify:no digest

There may be more to that message than was posted. You also did not give the file name nor the location from which it was downloaded.

Apparently you are using dnf to attempt the install and dnf routinely requires the packages to be gpg signed to verify the validity and without a matching key it can prevent an install.

Please post more info so we can see your full error message, and possibly test the install to see the error for ourselves.

I do mostly install rpm files rpm -U filename, after download. With trusted sources that works.

Tried it but still no result. I have contacted support and now I am waiting for a response from them.

1 Like

I will not install that package without a lot more research, but downloading it and a preliminary test for installing it with sudo dnf install ./utopia-latest.x86_64.rpm looks like it should work. It does not call out any dependencies at all on fedora 34 with the way my system is set up.

I also tried the same package on my fedora 35 system and had the same result.

I think your last failure may have been because you used the file name without the ‘path’ portion so dnf did not know to look at the file in the local directory. It tried to look for a package with that full name and not locally.

Thank you for your insight . I tried installing the said package using Virtual Box - on a Fedora 34 and I got a same responce. I will keep the post updated with all of the support replys for future reference.

Since you’re installing local *.rpm package, it should be using sudo dnf localinstall utopia-latest.x86_64.rpm on the directory where you save your package instead of dnf install.


I installed on Fedora 35 Workstation. It’s like another messaging app that focused on security and from my understanding it doesn’t have server but direct communication peer to peer. Btw it’s quite buggy sometime it just hang.

1 Like

Thank you for the update.