Users disappeared after logout (F37 WS GNOME)


My system is Fedora Workstation 37 GNOME.

The user accounts on my system just disappeared after I logged out of the session. The chain of events is as follows:

My laptop was asleep with a few apps opened. I woke it up and hit “logout” without exiting the apps. Instead of the login screen, I was presented with the default initial screen prompting me to create a user profile so that the system can initiate. I performed a cold reboot and was presented with the same first-boot-after-installation screen. I was forced to create a user account. After I logged in to the default F37 desktop I discovered that the home directories of my two previously created accounts are still there and all the files in them are present and accessible.

My old accounts are no longer displayed in the settings panel nor the login screen. I tried to log into my old accounts using the option for users that are not listed - no success there. The host name of my machine is still the same. The apps that I manually installed are still there. But I can not log into my old accounts.

The output of ls -l /home/ is:

общо 0
drwx------. 1 computer computer 424 29 яну 17:25 computer
drwx------. 1     1001 Didi     382  9 дек 21:56 Didi
drwx------. 1 computer lyubo    628 25 яну 12:43 lyubo

(The first line says “all” or “total” or something similar.) Didi (regular account) and lyubo (admin) are my old accounts and computer is the one I was forced to create.

The contents of /etc/passwd is:

ftp:x:14:50:FTP User:/var/ftp:/sbin/nologin
nobody:x:65534:65534:Kernel Overflow User:/:/sbin/nologin
systemd-network:x:192:192:systemd Network Management:/:/sbin/nologin
systemd-coredump:x:999:997:systemd Core Dumper:/:/sbin/nologin
systemd-resolve:x:193:193:systemd Resolver:/:/sbin/nologin
systemd-oom:x:998:996:systemd Userspace OOM Killer:/:/sbin/nologin
systemd-timesync:x:997:995:systemd Time Synchronization:/:/sbin/nologin
tss:x:59:59:Account used for TPM access:/dev/null:/sbin/nologin
dbus:x:81:81:System message bus:/:/sbin/nologin
polkitd:x:996:994:User for polkitd:/:/sbin/nologin
avahi:x:70:70:Avahi mDNS/DNS-SD Stack:/var/run/avahi-daemon:/sbin/nologin
unbound:x:995:992:Unbound DNS resolver:/etc/unbound:/sbin/nologin
dnsmasq:x:994:991:Dnsmasq DHCP and DNS server:/var/lib/dnsmasq:/sbin/nologin
nm-openconnect:x:993:989:NetworkManager user for OpenConnect:/:/sbin/nologin
usbmuxd:x:113:113:usbmuxd user:/:/sbin/nologin
gluster:x:992:988:GlusterFS daemons:/run/gluster:/sbin/nologin
pipewire:x:991:987:PipeWire System Daemon:/var/run/pipewire:/sbin/nologin
geoclue:x:990:986:User for geoclue:/var/lib/geoclue:/sbin/nologin
saslauth:x:988:76:Saslauthd user:/run/saslauthd:/sbin/nologin
radvd:x:75:75:radvd user:/:/sbin/nologin
rpc:x:32:32:Rpcbind Daemon:/var/lib/rpcbind:/sbin/nologin
qemu:x:107:107:qemu user:/:/sbin/nologin
nm-openvpn:x:986:981:Default user for running openvpn spawned by NetworkManager:/:/sbin/nologin
colord:x:985:980:User for colord:/var/lib/colord:/sbin/nologin
rpcuser:x:29:29:RPC Service User:/var/lib/nfs:/sbin/nologin
flatpak:x:984:979:User for flatpak system helper:/:/sbin/nologin
sshd:x:74:74:Privilege-separated SSH:/usr/share/empty.sshd:/sbin/nologin
tcpdump:x:72:72:er:/:/sbin/nologilyubo:x:1000:1000:Любомир Богоев:/home/lyubo:/bin/bash
akmods:x:981:974:User is used by akmods to build akmod packages:/var/cache/akmodsr:/:/sbin/nologipulse:x:171:171:PulseAudio System Daemon:/var/run/pulse:/sbin/nologin
firebird:x:980:971:er:/:/sbin/nologiDidi:x:1001:1001:Диана Ангелова:/home/Didi:/bin/bash

I suppose some machine error occurred that wiped my accounts from a list or something. I need help reinstating my old accounts so that I can log into them and use them again.

Thank you in advance!

Just logging out with apps open should not have corrupted files, so you could have encountered a filesystem bug or a hardware glitch. There may be other corrupt files, so a fresh install may be needed.

There is some information from the “lost” accounts in /etc/passwd. You might be able to fix it using vipw, but computer is using UID/GID 1000 that should belong to lyubo.

Corrupt tcpdump line shoudl probably be:


Corrupt akmods line should probably be:

akmods:x:981:974:User is used by akmods to build akmod packages:/var/cache/akmods/:/sbin/nologin

The missing entries appear to be present:

lyubo:x:1000:1000:Любомир Богоев:/home/lyubo:/bin/bash
Didi:x:1001:1001:Диана Ангелова:/home/Didi:/bin/bash

You could make the corrections in a recovery environment, or try correcting the entry for Didi first using the computer login, then logging in as Didi to correct the lyubo entry.

That is rather unfortunate to hear. Since I have access to all my files it would probably be wiser to resort to a fresh install in light of this risk.

1 Like

Probably a good Idea is to backup all files and check if memory and SSD/HD is ok before use them to make a new installation.

1 Like