Usb 3 port does not recognize device


I recently replaced my internal hdd with ssd. I got a sata external hard drive enclosure (link) so that I can use it as portable storage. The connector is mentioned as usb 3.1 gen 1 but its not getting recognised in my laptop’s usb 3.0 port. when connected to usb 2.0 ports, drive is getting recognised.
I have an old hp laptop (~2015) (link) with 1 usb 3.0 port and 2 usb 2.0 ports.

Bus 001 Device 002: ID 8087:8001 Intel Corp. Integrated Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 064e:930b Suyin Corp. HP Truevision HD
Bus 002 Device 003: ID 0a5c:216d Broadcom Corp. BCM43142A0 Bluetooth 4.0
Bus 002 Device 005: ID 2357:011f TP-Link 802.11ac WLAN Adapter 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
lsusb -d 1d6b:0003 -v

Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               3.00
  bDeviceClass            9 Hub
  bDeviceSubClass         0 
  bDeviceProtocol         3 
  bMaxPacketSize0         9
  idVendor           0x1d6b Linux Foundation
  idProduct          0x0003 3.0 root hub
  bcdDevice            6.01
  iManufacturer           3 Linux 6.1.15-200.fc37.x86_64 xhci-hcd
  iProduct                2 xHCI Host Controller
  iSerial                 1 0000:00:14.0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x001f
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              12
        bMaxBurst               0

I’m not sure how to debug the issue ?


Does the external enclosure have its own power supply?

If the device is not self-powered, check journalctl for messages related to usb and power (I don’t currently have USB power issues – someone else may be able to give a search pattern).

For all the details: v6.1 USB Port Power Control.

The fact that the enclosure is recognized on a usb 2 port and not a usb 3 port seems a bit off.
I have known of enclosure interfaces that were picky in that they would only work with a certain type of usb connection, and it sounds like you may have encountered one of those.

My suggestion – since enclosures are relatively inexpensive – replace it with a different brand. I have one made by rosewill for a 3.5 inch drive and it has worked flawlessly for years. Has its own external power supply for the drive.

1 Like

No, external enclosure dont have any other supply port.
Thanks for suggesting te journalctl. Though I’m novice user I will search for it. Maybe someone else faced something similar.

I have a second windows laptop ( different brand, ~2019, which I cannot format or dualboot). It has two 3.1 ports and tried the external enclosure. It works with both. I used linux-reader
Also there is an led indicator for power. So when I attach with fedora pc (usb 3.0) the indicator does turns on.
The indicator blinks when the device is busy and that’s not happening with fedora laptop but it blinks when i try reading in windows laptop. The device is not getting detected in gnome-disks or gparted in fedora.
So I think enclosure if fine. Any suggestions/thoughts ?

Your USB3 port may be dead or may not meet the power requirements of your external case. Sometimes accumulated dust and debris or corrosion prevents proper connection to the port.

Does the port work with low-power devices (mouse or keyboard)? Have you scanned dmesg and the journal for messages related to the port?

See: check how much power a USB port can deliver.

Yes the port works with usb2 devices. I tried figuring out the power drawn but it felt complicated and I found a different use case for the external disk. So I stopped researching about it.
Thank you for your time and replies.

This really sounds like the port may be bad, or have a corroded connection. You have a laptop so it would not necessarily be easy, but possibly cleaning and re-seating the connection to that port would work.