Upgraded from 29 to 30 Beta Nvidia issue

I upgraded from 29 to the 30 beta and am no longer able to blacklist nouveau. This has caused my Nvidia drivers to not load. Has any else seen this issue? I have it blacklisted in both grub and the blacklist file. In 29 once the nouveau driver was blacklisted I was able to use bumblebee to switch between intel and nvidia.

Did you blacklist it using rpm-ostree kargs as shown here?

No, I didn’t see that. Thank you, Ill try that and post if it works.

Isn’t this only when doing a silverblue install?

Ack sorry I had assumed that, for a while this forum was largely only used by Silverblue users… :sweat_smile:

Can you confirm if the grub command line option is set by hitting e on the GRUB boot screen? If nouveau is blacklisted there but is still being loaded, it’s likely due to a fallback, try running sudo akmods --force.

Looks like its not Nvidia but Bumblebee that is the issue.

Hi!
Any news regarding Bumblebee setup? Did you managed to get it working? I’m about to upgrade my ThinkPad W541 running F29 with Bumblebee (mixed Intel and Nvidia video) to F30 and I’m wondering if there will be any issues…
thanks!

Yes in another post someone recommended using these instructions.

https://docs.fedoraproject.org/en-US/quick-docs/bumblebee/

Which worked great.

The difference was on fedora 29 I was able to disable nvidia-fallback, but on fedora 30 I have to mask nvidia-fallback. Seems something else must have depended on it and be forcing it to start.

Also on the XPS Dell line you have to run:
sudo grubby --args=“acpi_rev_override pcie_port_pm=off” --update-kernel=ALL

But for you system I don’t think you will need that.

Tim

Thanks!
I realized that I used the instructions you mentioned… back in F24 times during initial setup. Since then I’m happily upgrading my OS to latest version every time it comes up.
Now I can confirm that once again, F29 -> F30 upgrade went smoothly!

cheers!