Upgrade to Fedora 35 (from 34) - new kernels are bootlooping?

Hi all!

I am on a Asus Flow X13 (2021) laptop, that has AMD Ryzen 9 5900HS.

I installed Fedora 34, and then immediately after I upgraded to F35.
F35 came with kernel 5.16.15, and the system would not boot using this kernel. No visible output on my screen, and it happens straight after selecting the OS in the grub entry.

I then selected my F34 kernel 5.11.12 and it booted fine. As just after installation, my laptop shortcuts for sleep, brightness and sound is not working, but i can adjust all this in the OS. [Fixed with kernel 5.15]

To add information, I was not able to boot into my F35 installation media either, I have explained the issue here; boot - Laptop reboots shortly after selecting grub entry on live USB - Ask Ubuntu - this is the reason I went via F34 as that worked.

Anyone who can help me troubeshoot this?

  1. [FIXED] ~The keyboard shortcuts ~
  2. The boot issue with kernels >= 5.16

[FIXED] I don’t know if I should await this issue; Sleep makes computer reboot when woken up.
I suspect the newer kernel may resolve that as well.
PS: Yep, new kernel indeed fixed it (5.15.18)

I appreciate your time!

Hi dennorske, if 5.15 worked fine, for starters you can use it.
Firstly use versionlock to make sure you won’t lose access to a working kernel:
sudo dnf versionlock add kernel*5.11.12*

Here’s how to install previous kernel quickly (make sure you’re installing the right version available in kernel | Package Info | koji):


You can also check other kernels from koji, maybe fresh 5.17 will be working.

Do you have any BIOS updates available?

1 Like

Appreciate your time!

I did not know i could version lock on dnf, so I will start by doing that.

And also, I will give 5.15 and 5.17 a try and see what results they yield for me, and report back here.

Thank you ~


Although looks like 5.15 is behaving weird (as in, it freezes occasionally) and reports nouveau issues;

But all shortcuts are working and system feels overall snappy now, which is a fantastic sign.

I will try 5.17 as well and see if it is any different. I am fairly new here btw, I hope it is not against the rules to post multiple times in a row like this? (I like to separate out actions and findings I do as in a timeline…)

EDIT: Kernel 5.17.0 was acting the same way as 5.16 - I had bootloops after grub. No output reported if i removed quiet from the grub cmd default on boot.

Some improvement, great!

About debugging boot problems, follow How to debug Dracut problems - Fedora Project Wiki.
You might try booting 5.16 or newer with initcall_blacklist=simpledrm_platform_driver_init kernel boot parameter, however there’s no indication yet that it’s the same problem as here https://www.reddit.com/r/openSUSE/comments/ss8aqg/tw_kernel_5168_broken/

nouveau is the open source nvidia driver, you can disable it to deactivate dGPU (like you tried on ubuntu forum) or, If you intend to use dedicated GPU, read Howto/NVIDIA - RPM Fusion.

Thanks again for your help!

I will go about debugging Dracut and see what it says.

The flag did not work, sadly - same same behaviour. I guess it is unrelated then.

When it comes to graphics driver, I attempted to follow the instructions, however it downloads and installs the 5.16 kernel headers in the process and when I reboot, it claims the nvidia module was not found and that it falls back to nouveau.

Is there any way I can force it to use my current kernel version for the installation?

Other than wanting a newer kernel and maybe experimenting if nvidia works, my system is almost running perfectly. Some actions make the system freeze for ~ 15 seconds but I will investigate and open a separate topic regarding this.

Make sure you have -devel and -headers packages for your latest working kernel version (from koji) and if that’s not enough, make dnf skip 5.16 version:
dnf install akmod-nvidia --exclude=kernel*5.16*

Installing Nvidia;
I tried installing NVIDIA, but I am struggling - It now wants to install 5.14 kernel packages, almost like 5.15 does not exist. Excluding 5.14 with the same as 5.16, here is my output;

$ sudo dnf install akmod-nvidia --exclude=kernel*5.16* --exclude=kernel*5.14*
Last metadata expiration check: 3:26:07 ago on Thu 24 Mar 2022 14:11:42 CET.
 Problem: package akmod-nvidia-3:510.47.03-2.fc35.x86_64 requires akmods, but none of the providers can be installed
  - package akmods-0.5.6-28.fc35.noarch requires kernel-devel-uname-r, but none of the providers can be installed
  - conflicting requests
  - package kernel-debug-devel-5.14.10-300.fc35.x86_64 is filtered out by exclude filtering
  - package kernel-devel-5.14.10-300.fc35.x86_64 is filtered out by exclude filtering
  - package kernel-debug-devel-5.16.16-200.fc35.x86_64 is filtered out by exclude filtering
  - package kernel-devel-5.16.16-200.fc35.x86_64 is filtered out by exclude filtering
(try to add '--skip-broken' to skip uninstallable packages)


I have also made sure that I have the necessary devel and headers packages, and all should be installed using [user@fedora ~]$ cd $(mktemp -d) && sudo koji download-build --arch=x86_64 --arch=noarch kernel-5.15.18-200.fc35 && sudo dnf upgrade *

But my installed packages are;

$ dnf list installed *kernel*
Installed Packages
abrt-addon-kerneloops.x86_64                                                                                             2.14.6-9.fc35                                                                                           @fedora      
kernel.x86_64                                                                                                            5.11.12-300.fc34                                                                                        @anaconda    
kernel.x86_64                                                                                                            5.15.18-200.fc35                                                                                        @@commandline
kernel.x86_64                                                                                                            5.17.0-128.eln115                                                                                       @@commandline
kernel-core.x86_64                                                                                                       5.11.12-300.fc34                                                                                        @anaconda    
kernel-core.x86_64                                                                                                       5.15.18-200.fc35                                                                                        @@commandline
kernel-core.x86_64                                                                                                       5.17.0-128.eln115                                                                                       @@commandline
kernel-modules.x86_64                                                                                                    5.11.12-300.fc34                                                                                        @anaconda    
kernel-modules.x86_64                                                                                                    5.15.18-200.fc35                                                                                        @@commandline
kernel-modules.x86_64                                                                                                    5.17.0-128.eln115                                                                                       @@commandline
kernel-modules-extra.x86_64                                                                                              5.11.12-300.fc34                                                                                        @anaconda    
kernel-modules-extra.x86_64                                                                                              5.15.18-200.fc35                                                                                        @@commandline
kernel-modules-extra.x86_64                                                                                              5.17.0-128.eln115                                                                                       @@commandline
libreport-plugin-kerneloops.x86_64                                                                                       2.15.2-8.fc35                                                                                           @updates  

Debugging Dracut
So I have tried my best to drop into a dracut shell, by removing “rhgb quiet” from my grub cmdline, and instead have rd.shell rd.debug log_bug_len=1M

Although, my screen stays completely blank, and I would expect at least some output on my screen. Could it indicate an issue with Dracut, or am I understanding incorrectly how it works?

there are also ways i can configure a serial console - however the guide says to look for /etc/grub.conf but I can only locate /etc/grub2.cnf - are these the same files?

That’s probably because at first dnf tried to install latest available versions (5.16), from updates repo, and when you blocked it, older ones (5.14 - the ones f35 shipped with) from fedora repo.

They are missing on your system. That one-liner ends with dnf upgrade *, so even though koji downloaded all the packages form that build, -devel and -headers packages were never installed on your system, so they were not used (upgraded). Download and install them manually for the first time from kernel-5.15.18-200.fc35 | Build Info | koji. After that dnf’ll keep updating them.

That guide haven’t been updated in a while, you need to (backup and) edit 5.16’s or 5.17’s entry in /boot/loader/entries/ or, while in grub after a reboot, select appropriate entry and press e, modify it (just for the current boot-up) and start by pressing Ctrl+x.

1 Like

Super, then I was not as far away from the right path as I initially thought!

So I’ve tried all available options from pressing e in the selecteed grub entry (both with kernels 5.16 and 5.17) and I am completely unable to see anything useful at all. There are no outputs, no fallback shell, and the laptop just instantaneously reboots after trying to load.
Could it be dracut causing the issue?

Pardon my lack of knowledge on fedora, this is my first time using it, and I truly appreciate you taking your time to come with useful input so far! I’ve learnt a lot.

Otherwise, I was able to install nvidia drivers now, and I am currently enjoying that and my external monitors are working perfectly. I also was lucky enough to get screen rotation working as a bonus.

Maybe someone else will know better how to deal with this issue. If not, report issues with booting 5.16+ here https://bugzilla.redhat.com/enter_bug.cgi?component=kernel&product=Fedora

1 Like

Yes. That is the current version (/etc/grub2.cfg) and the guide is based on a much older release.

The issue was with the BIOS from Asus.

The newest BIOS version 410 fixes the bootloop issues on newer kernels (5.16 -->).

I just want to also show my appreciation for your help and insight into the problem i was facing on this one. Without you I’d most likely not be using fedora as my daily driver today.

1 Like